Bug 973418 - CAVS test driver needs update for RHEL5
CAVS test driver needs update for RHEL5
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: libgcrypt (Show other bugs)
5.10
Unspecified Linux
high Severity high
: rc
: ---
Assigned To: Tomas Mraz
Ondrej Moriš
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-11 17:58 EDT by Ondrej Moriš
Modified: 2013-10-31 06:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-31 06:34:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ondrej Moriš 2013-06-11 17:58:43 EDT
Description of problem:

There is a CAVS test driver in libgcrypt which works fine on RHEL6, however on RHEL5 is fails as follows:

# ./cavs_tests.sh 
Running test file cavs/DSA2/req/SigGen.req
Using libgcrypt interface functions
Performing tests from source file cavs/DSA2/req/SigGen.req with results stored in destination file cavs/DSA2/req/SigGen.rsp
usage: fipsdrv [OPTION] [FILE] (try --help for more information)
system fipsdrv --keysize L=1024, N=160, SHA-1 rsa-gen > rsa_siggen.tmp.6978 failed: 512 at ./cavs_driver.pl line 438, <IN> line 6.
failed test: cavs/DSA2/req/SigGen.req rc=9
Error encountered - not packing up response file

Therefore it is clear that fipsdrv is called in a wrong way on RHEL5.

Version-Release number of selected component (if applicable):

libgcrypt-1.4.4-5.el5

How reproducible:

100%

Steps to Reproduce:

1. enable fips mode (put 1 into /etc/gcrypt/fips_enabled, for instance)
2. download test vectors [1]
3. build the source rpm 
4. copy the vectors into tests subdirectory
5. exeucte ./cavs_tests.sh

[1] http://nest.test.redhat.com/mnt/qa/scratch/omoris/cavs.tar.bz2

Additional info:

It might happen that CAVS test is not suitable for RHEL5, in such case, please feel free to close this BZ.
Comment 1 RHEL Product and Program Management 2013-06-11 18:18:47 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 Tomas Mraz 2013-06-12 03:44:47 EDT
Just drop the DSA2 test vectors from the test.
Comment 3 Tomas Mraz 2013-10-31 06:34:38 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being
addressed in Red Hat Enterprise Linux 5, and therefore will be closed.
If this bug is critical to production systems, please contact your Red
Hat support representative and provide sufficient business
justification.

Note You need to log in before you can comment on or make changes to this bug.