Bug 973501 - util-linux: agetty stuck in a loop in get_logname
util-linux: agetty stuck in a loop in get_logname
Status: CLOSED DUPLICATE of bug 972457
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Karel Zak
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 00:53 EDT by Florian Weimer
Modified: 2013-06-12 15:07 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-12 15:07:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Weimer 2013-06-12 00:53:37 EDT
Description of problem:

I have a freshly installed system where agetty is stuck in a loop in get_logname, in the while loop starting at line 1437 in term-utils/agetty.c.

Version-Release number of selected component (if applicable):

util-linux-2.23.1-2.fc19.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Boot the machine.
2. Attach strace to an agetty process (or watch CPU usage using top).

Actual results:

agetty consume CPU and strace shows nanosleep and read system calls.

Expected results:

agetty sleeps, and strace shows no output.

Additional info:

This is a fresh, minimal installation on real hardware.  I did not configure anything fancy, such as a serial console.  It's a fairly slow machine, so perhaps the issue is not as visible on faster hardware.
Comment 1 Karel Zak 2013-06-12 15:07:39 EDT

*** This bug has been marked as a duplicate of bug 972457 ***

Note You need to log in before you can comment on or make changes to this bug.