Bug 973527 - [RHSC] "Status of service type GLUSTER_SWIFT changed from <UNKNOWN> to <UNKNOWN> on cluster" - message seen when a host is added to a cluster from the Console.
[RHSC] "Status of service type GLUSTER_SWIFT changed from <UNKNOWN> to <UNKNO...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Shubhendu Tripathi
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 03:29 EDT by Shruti Sampat
Modified: 2013-09-23 18:25 EDT (History)
6 users (show)

See Also:
Fixed In Version: bb6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine logs (3.48 MB, text/x-log)
2013-06-12 06:11 EDT, Shruti Sampat
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15549 None None None Never

  None (edit)
Description Shruti Sampat 2013-06-12 03:29:27 EDT
Description of problem:
---------------------------------------
After adding a host to a cluster from the Console, the following messages are seen in the Events log -

Status of service type GLUSTER_SWIFT changed from <UNKNOWN> to <UNKNOWN> on cluster test32
Status of service type GLUSTER changed from <UNKNOWN> to <UNKNOWN> on cluster test32
Status of service type SMB changed from <UNKNOWN> to <UNKNOWN> on cluster test32

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb3.el6rhs 

How reproducible:
Intermittent

Steps to Reproduce:
1. Add a host to a cluster via the Console

Actual results:
The above described messages were seen in the Events log.

Expected results:
The message should not describe UNKNOWN as the status of the services.

Additional info:
Comment 2 Shruti Sampat 2013-06-12 06:11:08 EDT
Created attachment 760060 [details]
engine logs
Comment 3 Sahina Bose 2013-07-17 05:45:53 EDT
Fixed in bb6
Comment 4 Shruti Sampat 2013-07-19 03:05:56 EDT
Verified as fixed in bb6. The events log messages now say - 

Status of service type GLUSTER_SWIFT changed from Unknown to Down on cluster test
Status of service type GLUSTER changed from Unknown to Up on cluster test
Status of service type SMB changed from Unknown to Down on cluster test
Comment 5 Scott Haines 2013-09-23 18:25:47 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.