Bug 973568 - Link to dashbuilder application not working (BPM > Process & Task dashboard)
Link to dashbuilder application not working (BPM > Process & Task dashboard)
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: DR6
: 6.0.0
Assigned To: Mauricio Salatino
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 04:48 EDT by Jan Hrcek
Modified: 2014-08-06 16:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Wrong links on the home page and in the navigation pane of the business-central for Business Activity Monitoring (BAM) and Process & Tasks Dashboard. Consequence: Both the links either do not work or point to a wrong location. Fix: This has been fixed and the links now target to the desired location. Result: Users can now access both the links to access the home page and jBPM dashboard respectively in BAM application.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:09:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-06-12 04:48:01 EDT
Description of problem:
There are 2 places in the kie-workbench (aka business-central in productized version) that should forward user to bam application:
1) On the home page of application, the link named "Business Activity Monitoring"
2) In navigation menu - BPM > Process & Tasks Dashboard

Currently they do the following (tested with localhost deployment):
1) http://localhost:8080/bam-app/ (OK, link working, because productisation patched the webroot of the bam application)

2) http://localhost:8080/dashbuilder/workspace/jbpm-dashboard (not working because ot the same patch mentioned above)


Version-Release number of selected component (if applicable):
BPMS build DR5 (http://jawa05.englab.brq.redhat.com/candidate/BPMS-6.0.0-DR5/) deployed on JBoss EAP 6.1

How reproducible:
Always. 

Steps to Reproduce:
1. Login to application and use the two above mentioned ways to get from business-central into BAM application

Actual results:
One of the links is not working.

Expected results:
Both links should work and shoul point user to correct place (home page/jBPM dashboard respectively) in BAM application.

Additional info:
There are 2 related bugzillas opened:
https://bugzilla.redhat.com/show_bug.cgi?id=952552
https://bugzilla.redhat.com/show_bug.cgi?id=973283
Comment 1 Mauricio Salatino 2013-06-24 10:44:48 EDT
Fixed in master
Comment 3 Jan Hrcek 2013-07-11 08:49:06 EDT
Verified with BPMS DR6 deployed on EAP 6.1
Comment 7 Kanchan Desai 2013-10-29 02:12:07 EDT
Hi Jan,

Doc Text has been added. Can you please review the CCFR.

Note You need to log in before you can comment on or make changes to this bug.