Bug 973596 - agent cannot connect to server after full platform uninventory
agent cannot connect to server after full platform uninventory
Status: CLOSED CURRENTRELEASE
Product: JBoss Operations Network
Classification: JBoss
Component: UI (Show other bugs)
JON 3.2
Unspecified Unspecified
unspecified Severity high
: ---
: JON 3.2.0
Assigned To: RHQ Project Maintainer
Mike Foley
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 05:57 EDT by Armine Hovsepyan
Modified: 2015-09-02 20:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Armine Hovsepyan 2013-06-12 05:57:05 EDT
Description of problem:
agent cannot connect to server after full platform uninventory

Version-Release number of selected component (if applicable):
build:  2c9b8df

How reproducible:


Steps to Reproduce:
1. Install clean rhq with rhqctl install
2. inventory full agent platform
3. uninventory full platform

Actual results:
agent cannot connect to server
Administration -> agents -- no agent is connected
server log: 05:52:50,020 WARN  [org.rhq.enterprise.communications.command.server.CommandProcessor] (http-/0.0.0.0:7080-2) {CommandProcessor.failed-authentication}Command failed to be authenticated!  This command will be ignored and not processed: Command: type=[remotepojo]; cmd-in-response=[false]; config=[{rhq.agent-name=agentperfpostgres2.bc.jonqe.lab.eng.bos.redhat.com, rhq.security-token=B54nCQZZvUueEw6Mft7fk9vBr+Y1G+cL+WMfasIMnQqlwju08CksHYl8a3Ac4B330JU=, rhq.externalizable-strategy=AGENT, rhq.send-throttle=true, rhq.guaranteed-delivery=true}]; params=[{invocation=NameBasedInvocation[mergeMeasurementReport], targetInterfaceName=org.rhq.core.clientapi.server.measurement.MeasurementServerService}]



Expected results:
platform is re-discovered by server
rhq storage and platform are auto-inventoried to server


Additional info:
Comment 1 John Mazzitelli 2013-10-09 15:23:54 EDT
I tried these steps and my agent immediately re-registered and things worked.

If you look at the exception message in this BZ's description, you'll notice this was a message for sending up a measurement report (mergeMeasurementReport) but it was from an old resource that you just uninventoried. Measurement reports have guaranteed delivery, so the agent had spooled this message and when it tried to re-send it, it was for an old uninventoried resource now (in fact, its for the old agent itself that no longer is identified with the old token) so the message was rejected.

But this is OK. The agent will just throw that message away and keep going.

I think this is working as intended and expected behavior. Again, when I tried things, the agent was able to reconnect and reestablish itself after getting a new token.
Comment 2 Armine Hovsepyan 2013-10-10 10:20:20 EDT
verified
recorded video here -> http://d.pr/v/9pGa

Note You need to log in before you can comment on or make changes to this bug.