Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 973612 - [RHSC] Remove swift services related information from the General tab of a 3.1 cluster, remove hooks tab for a 3.1 cluster, and remove 'gluster swift' tab for hosts in a 3.1 cluster.
[RHSC] Remove swift services related information from the General tab of a 3....
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Kanagaraj
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 06:43 EDT by Shruti Sampat
Modified: 2016-04-18 06:06 EDT (History)
8 users (show)

See Also:
Fixed In Version: bb5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15785 None None None Never

  None (edit)
Description Shruti Sampat 2013-06-12 06:43:10 EDT
Description of problem:
---------------------------------------
Since management of swift related services is not supported for a cluster of 3.1 compatibility level, the information related to swift services should not be shown in the General tab for a 3.1 compatible cluster.

Remove the Gluster Swift tab for hosts in a 3.1 cluster.

Also remove the tab 'Gluster Hooks' for a 3.1 cluster as hooks management is also not supported.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb3.el6rhs 

How reproducible:
Always

Steps to Reproduce:
1.N/A
2.
3.

Actual results:
N/A

Expected results:
N/A

Additional info:
Comment 2 Shruti Sampat 2013-07-08 08:21:09 EDT
Verified as fixed in Red Hat Storage Console Version: 2.1.0-0.bb5.el6rhs.
Comment 3 Scott Haines 2013-09-23 18:25:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.