Bug 973624 - [RHSC] Events log message seen when a host goes to Non-Operational needs to be changed.
[RHSC] Events log message seen when a host goes to Non-Operational needs to b...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Shubhendu Tripathi
Shruti Sampat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 07:17 EDT by Shruti Sampat
Modified: 2013-09-23 18:25 EDT (History)
7 users (show)

See Also:
Fixed In Version: bb5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:25:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 15794 None None None Never

  None (edit)
Description Shruti Sampat 2013-06-12 07:17:21 EDT
Description of problem:
---------------------------------------
When a host goes to non-operational state from the UP state, the events log message looks like this -

Gluster command [<UNKNOWN>] failed on server <UNKNOWN>.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.0-0.bb3.el6rhs 

How reproducible:
Always.

Steps to Reproduce:
1. Add a host to a cluster via the Console and let it come UP.
2. Run the following command to stop glusterd on the host - 
   # service glusterd stop

Actual results:
The following message is seen in the Events log - 

Gluster command [<UNKNOWN>] failed on server <UNKNOWN>.

Expected results:
The message should say what the command was and which server it failed in, instead of 'UNKNOWN'.

Additional info:
Comment 3 Scott Haines 2013-09-23 18:25:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.