Bug 973642 - [RHSC-SHELL] listing permits of a role gives vm,template storagepool,rhevm.
[RHSC-SHELL] listing permits of a role gives vm,template storagepool,rhevm.
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc-cli (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Sahina Bose
RamaKasturi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 08:10 EDT by RamaKasturi
Modified: 2015-08-27 07:32 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-27 07:32:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2013-06-12 08:10:24 EDT
Description of problem:
listing permits of a role has vm,template storagepool,rhevm present in it.

Version-Release number of selected component (if applicable):
rhsc-cli-2.1.0.0-1.bb1.el6rhs.noarch

How reproducible:
Always

Steps to Reproduce:
1. connect to ovirt-shell.
2. type the command list permits --role-identifier SuperUser 
3.

Actual results:
id         : 100
name       : create_host

id         : 101
name       : edit_host_configuration

id         : 102
name       : delete_host

id         : 103
name       : maniputlate_host

id         : 104
name       : configure_host_network

id         : 200
name       : create_template

id         : 201
name       : edit_template_properties

id         : 202
name       : delete_template

id         : 203
name       : copy_template

id         : 204
name       : configure_template_network

id         : 400
name       : create_cluster

[OVIRT shell (connected)]# list permits --role-identifier SuperUser

id         : 100
name       : create_host

id         : 101
name       : edit_host_configuration

id         : 102
name       : delete_host

id         : 103
name       : maniputlate_host

id         : 104
name       : configure_host_network

id         : 200
name       : create_template

id         : 201
name       : edit_template_properties

id         : 202
name       : delete_template

id         : 203
name       : copy_template

id         : 204
name       : configure_template_network

id         : 400
name       : create_cluster


id         : 100
name       : create_host

id         : 101
name       : edit_host_configuration

id         : 102
name       : delete_host

id         : 103
name       : maniputlate_host

id         : 104
name       : configure_host_network

id         : 200
name       : create_template

id         : 201
name       : edit_template_properties

id         : 202
name       : delete_template

id         : 203
name       : copy_template

id         : 204
name       : configure_template_network

id         : 400
name       : create_cluster

id         : 401
name       : edit_cluster_configuration

id         : 402
name       : delete_cluster

id         : 403
name       : configure_cluster_network

id         : 500
name       : manipulate_users

id         : 501
name       : manipulate_roles

id         : 502
name       : manipulate_permissions

id         : 700
name       : create_storage_pool

id         : 701
name       : delete_storage_pool

id         : 702
name       : edit_storage_pool_configuration

id         : 703
name       : configure_storage_pool_network

id         : 800
name       : configure_rhevm

id         : 900
name       : configure_quota

id         : 901
name       : consume_quota

id         : 1100
name       : create_disk

id         : 1101
name       : attach_disk

id         : 1102
name       : edit_disk_properties

id         : 1103
name       : configure_disk_storage

id         : 1104
name       : delete_disk

id         : 1000
name       : create_gluster_volume

id         : 1001
name       : manipulate_gluster_volume

id         : 1002
name       : delete_gluster_volume

id         : 13
name       : reconnect_to_vm

id         : 1200
name       : port_mirroring

id         : 1300
name       : login

id         : 14
name       : change_vm_custom_properties

id         : 704
name       : create_storage_pool_network

id         : 705
name       : delete_storage_pool_network

id         : 404
name       : assign_cluster_network

id         : 1400
name       : inject_external_events

id         : 1003
name       : manipulate_gluster_hook

id         : 15
name       : edit_admin_vm_properties

id         : 205
name       : edit_admin_template_properties

id         : 1004
name       : manipulate_gluster_service


Expected results:
output should not have vm,storagepool, template ,rhevm,quotas and disk since rhsc does not support all these.

Additional info:
Comment 2 Dusmant 2015-08-27 07:32:35 EDT
We are not planning to fix it. Hence closing this BZ. If you think, it's applicable for 3.x release and would have an impact on customer, pls. open up a new BZ with the appropriate version. Thanks, -Dusmant

Note You need to log in before you can comment on or make changes to this bug.