Bug 973650 - FTBFS: rubygem-mail
Summary: FTBFS: rubygem-mail
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Software Collections
Classification: Red Hat
Component: rubygem-mail (Show other bugs)
(Show other bugs)
Version: ruby193
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
: 1.0
Assignee: Josef Stribny
QA Contact: Iveta Wiedermann
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 968295
TreeView+ depends on / blocked
 
Reported: 2013-06-12 12:40 UTC by Vít Ondruch
Modified: 2016-01-04 05:51 UTC (History)
3 users (show)

Fixed In Version: ruby193-rubygem-mail-2.4.4-4.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 17:44:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2013:1249 normal SHIPPED_LIVE new packages: ruby193 2013-09-10 21:41:53 UTC

Description Vít Ondruch 2013-06-12 12:40:49 UTC
Failures:
  1) Mail::Encodings altering an encoded text to decoded and visa versa unquote and convert to should unquote multiple strings in the middle of the text
     Failure/Error: b.should eq "日本語 <a@example.com>, 日本語 <b@example.com>"
       
       expected: "日本語 <a@example.com>, 日本語 <b@example.com>"
            got: "日本語= <a@example.com>, 日本語= <b@example.com>"
       
       (compared using ==)
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-expectations-2.11.1/lib/rspec/expectations/fail_with.rb:33:in `fail_with'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-expectations-2.11.1/lib/rspec/expectations/handler.rb:17:in `handle_matcher'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-expectations-2.11.1/lib/rspec/expectations/syntax.rb:48:in `should'
     # /builddir/build/BUILD/ruby193-rubygem-mail-2.4.4/opt/rh/ruby193/root/usr/share/gems/gems/mail-2.4.4/spec/mail/encodings_spec.rb:615:in `block (4 levels) in <top (required)>'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example.rb:113:in `instance_eval'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example.rb:113:in `block in run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example.rb:253:in `with_around_each_hooks'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example.rb:110:in `run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:378:in `block in run_examples'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:374:in `map'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:374:in `run_examples'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:360:in `run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:361:in `block in run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:361:in `map'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:361:in `run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:361:in `block in run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:361:in `map'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/example_group.rb:361:in `run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/command_line.rb:28:in `block (2 levels) in run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/command_line.rb:28:in `map'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/command_line.rb:28:in `block in run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/reporter.rb:34:in `report'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/command_line.rb:25:in `run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/runner.rb:69:in `run'
     # /opt/rh/ruby193/root/usr/share/gems/gems/rspec-core-2.11.1/lib/rspec/core/runner.rb:8:in `block in autorun'


I know that I saw that issue already somewhere. It is probably caused by update of Ruby patch release.

Comment 2 Josef Stribny 2013-06-13 09:29:15 UTC
Fixed by upstream in 2.5.0 or higher. I backported the first part of the commit[1] that handles this encoding issue for Ruby > 1.9.3.

[1] https://github.com/mikel/mail/commit/bb25038fa667273c136c6fb2823d01684999d252

Comment 6 errata-xmlrpc 2013-09-10 17:44:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1249.html


Note You need to log in before you can comment on or make changes to this bug.