Bug 973731 - Cannot build RichFaces Showcase with EAP 6.1 Maven repository
Cannot build RichFaces Showcase with EAP 6.1 Maven repository
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: RichFaces (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity high
: CR1
: 2.3.0
Assigned To: Brian Leathem
Pavol Pitonak
:
: 973732 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 11:03 EDT by Pavol Pitonak
Modified: 2013-07-16 07:11 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:11:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavol Pitonak 2013-06-12 11:03:20 EDT
Description of problem:
Several dependencies in RichFaces Showcase's pom.xml are outdated, i.e. they are not in EAP 6.1.0 Maven repository but they are in either EAP 6.0.0 or 6.0.1 Maven repositories.

At least these have to be updated:
hibernate-validator
slf4j-api
hornetq

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. unzip jboss-wfk-2.3.0.ER1-richfaces-demo.zip
2. cd jboss-wfk-2.3.0.ER1/demo/richfaces-4.3.2.Final-redhat-1/richfaces-showcase
3. mvn clean instal -s /path/to/custom/settings.xml

Actual results:
[ERROR] Failed to execute goal on project richfaces-showcase: Could not resolve dependencies for project org.richfaces.examples:richfaces-showcase:war:4.3.2.Final-redhat-1: The following artifacts could not be resolved: org.hibernate:hibernate-validator:jar:4.2.0.Final-redhat-2, org.slf4j:slf4j-api:jar:1.6.1-redhat-2, org.hornetq:hornetq-core:jar:2.2.23.Final-redhat-1, org.hornetq:hornetq-jms:jar:2.2.23.Final-redhat-1, org.hornetq:hornetq-logging:jar:2.2.23.Final-redhat-1, org.jboss.netty:netty:jar:3.2.6.Final-redhat-2, javax.inject:javax.inject:jar:1-redhat-2: Could not find artifact org.hibernate:hibernate-validator:jar:4.2.0.Final-redhat-2 in wfk-latest-enterprise-repository (file:///data/workspace/wfk/wfk-tools/maven-bootstrap/jboss-wfk-2.3.0.ER1-maven-repository) -> [Help 1]

Expected results:
Maven finishes successfully and showcase.war is in target directory.

Additional info:
Comment 1 Marek Novotny 2013-06-13 09:32:49 EDT
There is a question how you would like to handle changed hornetq version and its maven artifacts for hornetq 2.3.1.Final.

You should create the issue upstream too, as I need to know what solution is supported by Richfaces team - stay on hornetq 2.2.x or use changed GAV for 2.3.x
Comment 2 Marek Novotny 2013-06-13 10:06:33 EDT
*** Bug 973732 has been marked as a duplicate of this bug. ***
Comment 3 Marek Novotny 2013-06-24 03:22:34 EDT
I changed the showcase to use org.hornetq:hornetq-*:2.3.1.Final-redhat-1

http://git.app.eng.bos.redhat.com/?p=richfaces/showcase.git;a=commitdiff;h=c8a0440302c259dab5a8e7c42d4700b7cf41b565;hp=19e2d5328a7d0da7c2b4edc8a93dd01710a05e9b

The other thing broken in EAP 6.1.0 repository is missing some transitive dependencies related to and fixed by http://git.app.eng.bos.redhat.com/?p=richfaces/showcase.git;a=commitdiff;h=139ebd8745e90e5c5279882baf3259df70fa4358
Comment 5 Pavol Pitonak 2013-07-02 08:44:32 EDT
Verified.

Note You need to log in before you can comment on or make changes to this bug.