Bug 973744 - repo copy rpm with --recursive copies the dependencies but the output does not display them
Summary: repo copy rpm with --recursive copies the dependencies but the output does no...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: user-experience (Show other bugs)
(Show other bugs)
Version: 2.2 Beta
Hardware: Unspecified Unspecified
medium
unspecified
Target Milestone: ---
: 2.3.0
Assignee: Michael Hrivnak
QA Contact: Preethi Thomas
URL:
Whiteboard:
Keywords: Triaged
: 975569 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-12 15:29 UTC by Preethi Thomas
Modified: 2013-12-09 14:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 14:30:37 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Preethi Thomas 2013-06-12 15:29:23 UTC
Description of problem:
The --recursive option for copy rpm copies the dependencies but the out put does not indicate the dependencies copied

Version-Release number of selected component (if applicable):
[root@hp-dl360g6-01 ~]# rpm -q pulp-server
pulp-server-2.2.0-0.3.beta.fc18.noarch

How reproducible:


Steps to Reproduce:

[root@hp-dl360g6-01 ~]# 

repo copy rpm with --recursive no longer hangs. But it doesn't seem to be getting the dependencies for packages when recursive is specified.

[root@hp-dl360g6-01 ~]# pulp-admin rpm repo create --repo-id pulp --feed http://repos.fedorapeople.org/repos/pulp/pulp/v2/testing/fedora-18/x86_64/
Successfully created repository [pulp]


[root@hp-dl360g6-01 ~]# pulp-admin rpm repo create --repo-id pulp-copy
Successfully created repository [pulp-copy]

[root@hp-dl360g6-01 ~]# pulp-admin rpm repo sync run --repo-id pulp
+----------------------------------------------------------------------+
                    Synchronizing Repository [pulp]
+----------------------------------------------------------------------+

This command may be exited by pressing ctrl+c without affecting the actual
operation on the server.

Downloading metadata...
[\]
... completed

Downloading repository content...
[==================================================] 100%
RPMs:       43/43 items
Delta RPMs: 0/0 items

... completed

Downloading distribution files...
[==================================================] 100%
Distributions: 0/0 items
... completed

Importing errata...
[-]
... completed

Importing package groups/categories...
[-]
... completed

Publishing packages...
[==================================================] 100%
Packages: 43/43 items
... completed

Publishing distributions...
[==================================================] 100%
Distributions: 0/0 items
... completed

Generating metadata
[-]
... completed

Publishing repository over HTTPS
[-]
... completed

[root@hp-dl360g6-01 ~]#  pulp-admin rpm repo copy rpm  --from-repo-id pulp --to-repo-id pulp-copy --str-eq 'name=pulp-agent'  --recursive
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...

[-]
Running...

Units:
  pulp-agent-2.2.0-0.3.beta.fc18-noarch

[root@hp-dl360g6-01 ~]#  pulp-admin rpm repo copy rpm  --from-repo-id pulp --to-repo-id pulp-copy --str-eq 'name=pulp-server'  --recursive
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...

[-]
Running...

Units:
  pulp-server-2.2.0-0.3.beta.fc18-noarch

Actual results:


Expected results:


Additional info:

Comment 1 Michael Hrivnak 2013-06-24 17:10:34 UTC
*** Bug 975569 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Ortel 2013-09-18 23:58:47 UTC
build: 2.3.0-0.14.alpha

Comment 3 Preethi Thomas 2013-09-19 20:18:50 UTC
[root@pulp-v2-server ~]# rpm -qa pulp-server
pulp-server-2.3.0-0.14.alpha.el6.noarch
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# pulp-admin rpm repo copy rpm  --from-repo-id pulp --to-repo-id pulp-copy --str-eq 'name=pulp-agent'  --recursive
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...

[-]
Running...

Units:
  gofer-0.76-1.fc19-noarch
  pulp-agent-2.3.0-0.14.alpha.fc19-noarch

[root@pulp-v2-server ~]# 

[root@pulp-v2-server ~]#  pulp-admin rpm repo copy rpm  --from-repo-id pulp --to-repo-id pulp-copy --str-eq "name=pulp-server" --recursive
This command may be exited via ctrl+c without affecting the request.

[-]
Waiting to begin...

[-]
Running...

Units:
  m2crypto-0.21.1.pulp-8.fc19-x86_64
  mod_wsgi-3.4-1.pulp.fc19-x86_64
  pulp-server-2.3.0-0.14.alpha.fc19-noarch
  python-gofer-0.76-1.fc19-noarch
  python-isodate-0.5.0-1.pulp.fc19-noarch
  python-nectar-1.1.1-1.fc19-noarch
  python-oauth2-1.5.170-3.pulp.fc19-noarch
  python-okaara-1.0.32-1.fc19-noarch
  python-qpid-0.7.946106-2.fc19-noarch
  python-webpy-0.32-9.fc19-noarch

Comment 4 Preethi Thomas 2013-12-09 14:30:37 UTC
Pulp 2.3 released.


Note You need to log in before you can comment on or make changes to this bug.