Bug 973785 - Promoting a refreshed view fails
Summary: Promoting a refreshed view fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
(Show other bugs)
Version: 6.0.1
Hardware: Unspecified Unspecified
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Og Maciel
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-12 18:04 UTC by David Davis
Modified: 2013-07-18 21:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 21:21:59 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Davis 2013-06-12 18:04:55 UTC
Description of problem:

Promoting a refreshed content view throws an error.

2013-06-12T13:24:15-0400: [Worker(delayed_job host:f18 pid:5095)] PromotionChangeset#promote_content failed with TypeError: can't convert Symbol into Integer - 0 failed attempts
2013-06-12T13:24:15-0400: [Worker(delayed_job host:f18 pid:5095)] PERMANENTLY removing PromotionChangeset#promote_content because of 1 consecutive failures.
can't convert Symbol into Integer
/home/dadavis/Projects/katello/app/models/pulp_task_status.rb:55:in `[]'
/home/dadavis/Projects/katello/app/models/pulp_task_status.rb:55:in `using_pulp_task'
/home/dadavis/Projects/katello/app/models/pulp_task_status.rb:32:in `block in wait_for_tasks'
/home/dadavis/Projects/katello/app/models/pulp_task_status.rb:31:in `collect'
/home/dadavis/Projects/katello/app/models/pulp_task_status.rb:31:in `wait_for_tasks'
/home/dadavis/Projects/katello/app/models/content_view.rb:214:in `promote'
/home/dadavis/Projects/katello/app/models/promotion_changeset.rb:150:in `block in promote_views'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/activerecord-3.2.12/lib/active_record/relation/delegation.rb:6:in `collect'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/activerecord-3.2.12/lib/active_record/relation/delegation.rb:6:in `collect'
/home/dadavis/Projects/katello/app/models/promotion_changeset.rb:149:in `promote_views'
/home/dadavis/Projects/katello/app/models/promotion_changeset.rb:85:in `promote_content'
/home/dadavis/Projects/katello/app/models/async_operation.rb:58:in `perform'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/backend/base.rb:95:in `block in invoke_job'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `block in initialize'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:38:in `run_callbacks'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/backend/base.rb:92:in `invoke_job'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:203:in `block (2 levels) in run'
/home/dadavis/.rvm/rubies/ruby-1.9.3-p429/lib/ruby/1.9.1/timeout.rb:69:in `timeout'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:203:in `block in run'
/home/dadavis/.rvm/rubies/ruby-1.9.3-p429/lib/ruby/1.9.1/benchmark.rb:295:in `realtime'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:202:in `run'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:259:in `block in reserve_and_run_one_job'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `block in initialize'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:38:in `run_callbacks'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:259:in `reserve_and_run_one_job'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:187:in `block in work_off'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:186:in `times'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:186:in `work_off'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:151:in `block (4 levels) in start'
/home/dadavis/.rvm/rubies/ruby-1.9.3-p429/lib/ruby/1.9.1/benchmark.rb:295:in `realtime'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:150:in `block (3 levels) in start'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `block in initialize'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:38:in `run_callbacks'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:149:in `block (2 levels) in start'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:148:in `loop'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:148:in `block in start'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/plugins/clear_locks.rb:7:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/plugins/clear_locks.rb:7:in `block (2 levels) in <class:ClearLocks>'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:78:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:78:in `block (2 levels) in add'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:60:in `block in initialize'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:78:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:78:in `block in add'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `call'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:65:in `execute'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/lifecycle.rb:38:in `run_callbacks'
/home/dadavis/.rvm/gems/ruby-1.9.3-p429@katello/gems/delayed_job-3.0.5/lib/delayed/worker.rb:147:in `start'



Steps to Reproduce:
1. Create a view
2. Refresh that view
3. Promote the view


Actual results:

Throws an exception.


Expected results:

View is promoted successfully.

Comment 2 Brad Buckingham 2013-06-12 19:13:51 UTC
katello pull request:

https://github.com/Katello/katello/pull/2482

Comment 4 Brad Buckingham 2013-06-15 00:08:45 UTC
Mass move to ON_QA

Comment 5 Og Maciel 2013-06-17 22:30:53 UTC
Verified:
* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.9-1.el6_4.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.9-1.el6_4.noarch
* candlepin-tomcat6-0.8.9-1.el6_4.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* foreman-1.1.10011-1.noarch
* foreman-compute-1.1.10011-1.noarch
* foreman-installer-puppet-concat-0-2.d776701.git.0.21ef926.el6sat.noarch
* foreman-installer-puppet-dhcp-0-5.3a4a13c.el6sat.noarch
* foreman-installer-puppet-dns-0-7.fcae203.el6sat.noarch
* foreman-installer-puppet-foreman-0-6.568c5c4.el6sat.noarch
* foreman-installer-puppet-foreman_proxy-0-8.bd1e35d.el6sat.noarch
* foreman-installer-puppet-puppet-0-3.ab46748.el6sat.noarch
* foreman-installer-puppet-tftp-0-5.ea6c5e5.el6sat.noarch
* foreman-installer-puppet-xinetd-0-50a267b8.git.0.44aca6a.el6sat.noarch
* foreman-libvirt-1.1.10011-1.noarch
* foreman-postgresql-1.1.10011-1.noarch
* foreman-proxy-1.1.10003-1.el6sat.noarch
* foreman-proxy-installer-1.0.1-10.f5ae2cd.el6sat.noarch
* katello-1.4.2-14.el6sat.noarch
* katello-all-1.4.2-14.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.2-7.el6sat.noarch
* katello-cli-common-1.4.2-7.el6sat.noarch
* katello-common-1.4.2-14.el6sat.noarch
* katello-configure-1.4.3-16.el6sat.noarch
* katello-configure-foreman-1.4.3-16.el6sat.noarch
* katello-foreman-all-1.4.2-14.el6sat.noarch
* katello-glue-candlepin-1.4.2-14.el6sat.noarch
* katello-glue-elasticsearch-1.4.2-14.el6sat.noarch
* katello-glue-pulp-1.4.2-14.el6sat.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.4.3-3.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-rpm-plugins-2.1.2-0.3.beta.el6sat.noarch
* pulp-selinux-2.1.2-0.3.beta.el6sat.noarch
* pulp-server-2.1.2-0.3.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.18-1.el6sat.noarch
* signo-katello-0.0.18-1.el6sat.noarch

Comment 6 Mike McCune 2013-07-18 21:21:59 UTC
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.


Note You need to log in before you can comment on or make changes to this bug.