Bug 973815 - simple-scan does not detect wireless scanner
simple-scan does not detect wireless scanner
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: sane-backends (Show other bugs)
18
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 16:17 EDT by pgaltieri
Modified: 2014-02-05 18:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 18:11:38 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
epson2.conf for F16 (376 bytes, text/plain)
2013-06-24 12:47 EDT, pgaltieri
no flags Details
epson2.conf for F18 (376 bytes, text/plain)
2013-06-24 12:47 EDT, pgaltieri
no flags Details

  None (edit)
Description pgaltieri 2013-06-12 16:17:56 EDT
Description of problem:
I have a wireless all in one printer on my home network.  The simple-scan application does not see the scanner despite the fact I can ping the device.

Version-Release number of selected component (if applicable):
simple-scan.i686                     3.6.0-1.fc18

How reproducible:
Always

Steps to Reproduce:
1. Attach Epson Workforce 633 all in one printer
2. Run simple-scan
3.

Actual results:
Scanner not found

Expected results:
Scans image from scanner

Additional info:
This works fine on F16

Packages installed:
libsane-hpaio.i686                   3.13.3-2.fc18                     @updates 
sane-backends.i686                   1.0.23-7.fc18                     @updates 
sane-backends-drivers-scanners.i686  1.0.23-7.fc18                     @updates 
sane-backends-libs.i686              1.0.23-7.fc18                     @updates

Output of  SANE_DEBUG_DLL=2 SANE_DEBUG_EPSON2=2 scanimage -L on F18
[sanei_debug] Setting debug level of dll to 2.
[dll] sane_init: SANE dll backend version 1.0.13 from sane-backends 1.0.23
[dll] load: couldn't find backend `pint' (No such file or directory)
[sanei_debug] Setting debug level of epson2 to 2.
[epson2] sane_epson2_init: sane-backends 1.0.23
[epson2] epson2 backend, version 1.0.124

No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
[dll] sane_exit: exiting

sane-find-scanners also fails to find the scanner, but it also fails to find the scanner on F16

Output of  SANE_DEBUG_DLL=2 SANE_DEBUG_EPSON2=2 scanimage -L on F16
[sanei_debug] Setting debug level of dll to 2.
[dll] sane_init: SANE dll backend version 1.0.13 from sane-backends 1.0.23
[dll] load: couldn't find backend `pint' (No such file or directory)
[sanei_debug] Setting debug level of epson2 to 2.
[epson2] sane_epson2_init: sane-backends 1.0.23
[epson2] epson2 backend, version 1.0.124
[epson2] sanei_epson_net_lock
[epson2] status: 12
[epson2]  ready
[epson2]  option equipment is installed
[epson2]  support extended commands
[epson2] detection with request_extended_identity
[epson2]  command level   : D7
[epson2]  basic resolution: 2400
[epson2]  min resolution  : 75
[epson2]  max resolution  : 2400
[epson2]  max pixel num   : 32752
[epson2]  scan area       : 20400x28080
[epson2]  adf area        : 20400x33600
[epson2]  tpu area        : 0x0
[epson2]  capabilities (1): 0x01
[epson2]  capabilities (2): 0x00
[epson2]  input depth     : 16
[epson2]  max output depth: 8
[epson2]  rom version     : 1.70
[epson2]  model name      : PID 085D        
[epson2] options:
[epson2]  ADF detected
[epson2] capabilities (1):
[epson2]  push button is supported
[epson2] e2_set_cmd_level: D7
[epson2] maximum supported color depth: 8
[epson2] setting focus is not supported
[epson2] global status   : 0x01
[epson2]  warmup can be cancelled
[epson2] adf status      : 0x80
[epson2] tpu status      : 0x00
[epson2] device type     : 0xc0
[epson2] main body status: 0x00
[epson2] CCT model id is 0x00, profile offset 0
[epson2] cannot obtain resolution list, faking (75-2400)
[epson2] highest available resolution: 2400
[epson2] scanner model: PID 085D
[epson2] sanei_epson_net_unlock
[epson2]  0 (4): PID 085D
device `v4l:/dev/video0' is a Noname UVC Camera (046d:08c5) virtual device
device `epson2:net:192.168.0.2' is a Epson PID 085D flatbed scanner
device `hpaio:/net/HP_LaserJet_M1522nf_MFP?ip=10.0.0.72' is a Hewlett-Packard HP_LaserJet_M1522nf_MFP all-in-one
[dll] sane_exit: exiting
Comment 1 Rahul Sundaram 2013-06-12 18:35:44 EDT
Please file this upstream at https://launchpad.net/simple-scan
Comment 2 pgaltieri 2013-06-12 21:07:58 EDT
This problem may not be a simple-scan issue.  I reported it against simple-scan because that's how I found the problem.  I tried using xsane and had the same problem so this could be a sane-backends issue.
Comment 3 Nils Philippsen 2013-06-24 10:33:13 EDT
Hi. What version of sane-backends where you using on F-16? Please attach the file /etc/sane.d/epson2.conf from both machines to this ticket. Thanks!
Comment 4 pgaltieri 2013-06-24 12:47:07 EDT
Created attachment 764711 [details]
epson2.conf for F16
Comment 5 pgaltieri 2013-06-24 12:47:47 EDT
Created attachment 764712 [details]
epson2.conf for F18
Comment 6 pgaltieri 2013-06-24 12:48:46 EDT
The two files are attached, but there is no difference between the two
Comment 7 Nils Philippsen 2013-06-25 05:40:37 EDT
Hmm. How is the firewall configuration on the two machines, are there differences which could play into this?
Comment 8 pgaltieri 2013-06-25 14:04:22 EDT
I can connect to the printer with firefox so the device is accessible.  There doesn't seem to be anything specific in the F16 firewall, or the F18 firewall that would explain things. I tried running xsane again today and got the following error in /var/log/messages

Jun 25 10:07:35 darkstar xsane: io/hpmud/pp.c 627: unable to read device-id ret=-1

I updated today and one of the packages that was updated was libsane-hpaio-3.13.5-1.fc18.i686.

This has nothing to do with this issue, but I thought I'd mention it.

I looked at what was going on with wireshark and the problem is a routing issue.  The F18 system is on the 192.168.10.0/24 network (192.168.10.70) and the scanner is on the 192.168.0.0/24 network (192.168.0.2). The F16 system is connected to both the 192.168.10.0/24 network and the 192.168.0.0/24 networks (192.168.10.2 and 192.168.0.3) and is running as a router. Since the scanner discovery message sent by 192.168.10.70 goes out as a broadcast packet. and sice routers don't forward broadcasts, the scanner discovery packets never get sent to the scanner.

The fundamental problem is that there is no way in simple-scan, and I suspect the same is true of xsane, to explicitly provide the address of the scanner, at least I couldn't figure out how to do it. So eventhough the scanner is reachable it isn't usable.

So it comes down to this, if there was a way to tell simple scan the address of the scanner things might work just fine.  

I can understand if you want to close this bug as wont fix or as a request for enhancement.
Comment 9 Fedora End Of Life 2013-12-21 10:33:27 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2014-02-05 18:11:38 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.