Bug 973824 - Openshift Jboss - Unable to customize packaged Hibernate version
Openshift Jboss - Unable to customize packaged Hibernate version
Status: CLOSED NOTABUG
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
: SupportQuestion
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 17:07 EDT by pyrotek2k4
Modified: 2015-05-14 19:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 15:51:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pyrotek2k4 2013-06-12 17:07:32 EDT
Description of problem:

Per my original posting here:

https://www.openshift.com/forums/openshift/jboss-as7-unable-to-upgrade-hibernate-version

The version of Hibernate that is packaged with JBoss AS7 contains a defect which breaks my java application. I am currently using Hibernate version 4.1.8 where this issue has been corrected. I would like to upgrade the Hibernate jars packaged with JBoss per the following guide:

https://community.jboss.org/thread/195105

Unfortunately the directory references in step #2 above is sym-linked to a root owned directory and I am unable to upload new jars. 

Due to the inability to upload new Hibernate jars I am forced to go with a DIY glassfish installation which is less than ideal.

Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. Deploy an application which depends on any bug fixes post JBoss Hibernate packaged version
2. Observe Hibernate error and stacktrace when loading the website
3.

Actual results:

The Jboss modules and directory are owned by root and not my openshift user id.

Expected results:

The Jboss modules and directory are owned by my openshift user id and I can modify them at will.

Additional info:
Comment 1 pyrotek2k4 2013-06-17 15:42:54 EDT
I fixed this problem by utilizing the modules directory within the .openshift directory and things are now working as expected. Please withdraw this defect.

Note You need to log in before you can comment on or make changes to this bug.