Bug 973870 - [abrt] WARNING: at net/mac80211/util.c:599 ieee80211_can_queue_work.isra.7+0x32/0x40 [mac80211]()
[abrt] WARNING: at net/mac80211/util.c:599 ieee80211_can_queue_work.isra.7+0x...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
abrt_hash:283492fc8e9ef83c332b1129266...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-12 23:02 EDT by Vinod Kutty
Modified: 2016-01-26 12:18 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-20 09:38:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (198.81 KB, text/plain)
2013-06-12 23:02 EDT, Vinod Kutty
no flags Details

  None (edit)
Description Vinod Kutty 2013-06-12 23:02:50 EDT
Description of problem:
Resumed from suspend, then immediately logged in.

Additional info:
reporter:       libreport-2.1.4
WARNING: at net/mac80211/util.c:599 ieee80211_can_queue_work.isra.7+0x32/0x40 [mac80211]()
Hardware name: Dell System XPS L322X
queueing ieee80211 work while going to suspend
Modules linked in: cpufreq_stats iwldvm mac80211 iwlwifi cfg80211 ses enclosure usb_storage ebtable_nat xt_CHECKSUM bridge stp llc ppdev parport_pc parport fuse nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables vsock vfat fat snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep arc4 snd_seq iTCO_wdt snd_seq_device iTCO_vendor_support snd_pcm dell_wmi sparse_keymap uvcvideo acpi_cpufreq dell_laptop mperf videobuf2_vmalloc coretemp dcdbas videobuf2_memops videobuf2_core snd_page_alloc videodev snd_timer btusb bluetooth media microcode joydev snd rfkill soundcore lpc_ich mei i2c_i801 mfd_core vhost_net tun macvtap macvlan kvm_intel kvm uinput dm_crypt i915 crc32_pclmul crc32c_intel i2c_algo_bit drm_kms_helper drm ghash_clmulni_intel i2c_core wmi video sunrpc [last unloaded: cfg80211]
Pid: 24490, comm: pm-suspend Not tainted 3.9.4-200.fc18.x86_64 #1
Call Trace:
 <IRQ>  [<ffffffff8105f125>] warn_slowpath_common+0x75/0xa0
 [<ffffffffa06da410>] ? ieee80211_sta_conn_mon_timer+0x40/0x40 [mac80211]
 [<ffffffff8105f206>] warn_slowpath_fmt+0x46/0x50
 [<ffffffffa06bf722>] ieee80211_can_queue_work.isra.7+0x32/0x40 [mac80211]
 [<ffffffffa06bf7be>] ieee80211_queue_work+0x2e/0x50 [mac80211]
 [<ffffffffa06da44a>] ieee80211_sta_bcn_mon_timer+0x3a/0x40 [mac80211]
 [<ffffffff8106dbca>] call_timer_fn+0x3a/0x110
 [<ffffffffa06da410>] ? ieee80211_sta_conn_mon_timer+0x40/0x40 [mac80211]
 [<ffffffff8106f946>] run_timer_softirq+0x1f6/0x2a0
 [<ffffffff810677d0>] __do_softirq+0xe0/0x220
 [<ffffffff81067a95>] irq_exit+0xa5/0xb0
 [<ffffffff8166bc8e>] smp_apic_timer_interrupt+0x6e/0x99
 [<ffffffff8166ab5d>] apic_timer_interrupt+0x6d/0x80
 <EOI>  [<ffffffff81661561>] ? _raw_spin_unlock_irqrestore+0x11/0x20
 [<ffffffff810a1c47>] update_runtime+0xb7/0xd0
 [<ffffffff8166591d>] notifier_call_chain+0x4d/0x70
 [<ffffffff8108831e>] __raw_notifier_call_chain+0xe/0x10
 [<ffffffff81062ad0>] __cpu_notify+0x20/0x40
 [<ffffffff8164720f>] _cpu_down+0x7f/0x270
 [<ffffffff81062dce>] disable_nonboot_cpus+0x8e/0x120
 [<ffffffff810a8b9d>] suspend_devices_and_enter+0x27d/0x420
 [<ffffffff810a8eda>] pm_suspend+0x19a/0x230
 [<ffffffff810a7d17>] state_store+0x87/0xf0
 [<ffffffff8130325f>] kobj_attr_store+0xf/0x20
 [<ffffffff81214a58>] sysfs_write_file+0xd8/0x150
 [<ffffffff811a003c>] vfs_write+0xac/0x180
 [<ffffffff811a04d2>] sys_write+0x52/0xa0
 [<ffffffff816658ce>] ? do_page_fault+0xe/0x10
 [<ffffffff81669f59>] system_call_fastpath+0x16/0x1b
Comment 1 Vinod Kutty 2013-06-12 23:02:58 EDT
Created attachment 760422 [details]
File: dmesg
Comment 2 Stanislaw Gruszka 2013-08-23 04:00:34 EDT
I think, this should be fixed on 3.10 kernel. Can you still reproduce this particular trace when suspending on 3.10 ?
Comment 3 Justin M. Forbes 2013-10-18 17:21:48 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 4 Vinod Kutty 2016-01-26 12:18:02 EST
Filling this out for completeness (thanks to the nagware).

Haven't experienced the problem in newer kernels.

However, NB: the frequency was far higher on a corporate network with WPA2 Enterprise and lots of access points. I don't have the same setup to test with further.

Note You need to log in before you can comment on or make changes to this bug.