Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 973897 - Cannot modify transaction policy setting for a component implementation
Cannot modify transaction policy setting for a component implementation
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER2
: ---
Assigned To: Rob Cernich
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 01:21 EDT by Jiri Pechanec
Modified: 2014-06-16 19:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1526 Major Closed Cannot set properly transaction policy 2014-06-16 19:47:42 EDT

  None (edit)
Description Jiri Pechanec 2013-06-13 01:21:44 EDT
1) Select a component in SY editor, show window Properties
2) Go to Transaction Policy tab - choose managedTransaction.Global
3) Save switchyard.xml
4) A switchyard.xml now contains requires="managedTransaction.Global" on a implementation element
4) Change the policy to any other value
5) Save switchyard.xml
6) GUI editor show new value but the switchyard.xml still contains requires="managedTransaction.Global" instead of new value
Comment 1 Jiri Pechanec 2013-06-13 01:29:23 EDT
The issue is not present for setting a transaction policy on service, only on implementation
Comment 2 Brian Fitzpatrick 2013-06-21 17:13:21 EDT
Was fixed with changes made via JIRA SWITCHYARD-1526
Comment 3 Jiri Pechanec 2013-09-17 02:11:15 EDT
Verified in ER2
Comment 4 JBoss JIRA Server 2013-09-17 09:22:15 EDT
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira SWITCHYARD-1526

Verifies with JBTIS 4.1.3.Beta2 (JBDSIS 7.0.0.Beta2)
Comment 5 JBoss JIRA Server 2013-09-17 09:23:06 EDT
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira SWITCHYARD-1526

Verified with JBTIS 4.1.3.Beta2 (JBDSIS 7.0.0.Beta2). This issue can be closed (I don't have a permission to do that)
Comment 9 JBoss JIRA Server 2014-06-16 19:47:43 EDT
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1526 to Closed

Note You need to log in before you can comment on or make changes to this bug.