Bug 973898 - Editor incorrectly interprets None value for transaction policy setting
Summary: Editor incorrectly interprets None value for transaction policy setting
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Tooling (Show other bugs)
(Show other bugs)
Version: 6.0.0 GA
Hardware: Unspecified Unspecified
unspecified
high
Target Milestone: ER2
: ---
Assignee: Rob Cernich
QA Contact: Len DiMaggio
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-13 05:26 UTC by Jiri Pechanec
Modified: 2014-06-16 23:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker SWITCHYARD-1526 Major Closed Cannot set properly transaction policy 2014-06-16 23:47:42 UTC

Description Jiri Pechanec 2013-06-13 05:26:27 UTC
1) Select a component in SY editor, show window Properties
2) Go to Transaction Policy tab - choose None (albeit the value is alread at None, still choose it explicitly)
3) Save switchyard.xml
4) A switchyard.xml now contains requires="None" on a implementation element
Such a value is not supported by the SY runtime and the server startup will fail. The correct value would be empty string and if the element requires would be completely empty, then it has to be removed

Comment 1 Jiri Pechanec 2013-06-13 05:29:25 UTC
The issue is not present for setting a transaction policy on service, only on implementation

Comment 2 Brian Fitzpatrick 2013-06-21 21:14:16 UTC
This was handled in the changes for JIRA SWITCHYARD-1526

Comment 3 Jiri Pechanec 2013-09-17 07:01:30 UTC
Verified in ER2

Comment 4 JBoss JIRA Server 2013-09-17 13:22:13 UTC
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira SWITCHYARD-1526

Verifies with JBTIS 4.1.3.Beta2 (JBDSIS 7.0.0.Beta2)

Comment 5 JBoss JIRA Server 2013-09-17 13:23:05 UTC
Andrej Podhradsky <apodhrad@redhat.com> made a comment on jira SWITCHYARD-1526

Verified with JBTIS 4.1.3.Beta2 (JBDSIS 7.0.0.Beta2). This issue can be closed (I don't have a permission to do that)

Comment 9 JBoss JIRA Server 2014-06-16 23:47:43 UTC
Keith Babo <kbabo@redhat.com> updated the status of jira SWITCHYARD-1526 to Closed


Note You need to log in before you can comment on or make changes to this bug.