Bug 973923 - Cannot review packages because of unknown reason
Cannot review packages because of unknown reason
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-review (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 02:46 EDT by Christopher Meng
Modified: 2013-06-13 03:19 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 03:15:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedora-review error log (5.11 KB, text/x-log)
2013-06-13 03:11 EDT, Christopher Meng
no flags Details

  None (edit)
Description Christopher Meng 2013-06-13 02:46:57 EDT
Hi,

The SRPM is here:

http://cicku.me/tcpcopy-0.8.0-2.fc20.src.rpm

Can you help take a look at it? I'm not sure what's wrong with it.

[rpmaker@fab SRPMS]$ rpm -qa|grep fedora-review
fedora-review-0.4.1-2.fc20.noarch
Comment 1 Alec Leamas 2013-06-13 03:01:48 EDT
...or wrong with fedora-review ;) Could you please run fedora-review on the failing package and attach the logfile (~/.cache/fedora-review.log) here?
Comment 2 Christopher Meng 2013-06-13 03:11:04 EDT
Created attachment 760496 [details]
fedora-review error log
Comment 3 Alec Leamas 2013-06-13 03:15:24 EDT
The error message in the log file is pretty clear - package does not build in mock. From the logfile (path in fedora-review..og):

+ cd /builddir/build/BUILD

+ cd tcpcopy-0.8.0

+ ./autogen.sh

./autogen.sh: line 1: autoreconf: command not found
error: Bad exit status from /var/tmp/rpm-tmp.jiiDVK (%build)
    Bad exit status from /var/tmp/rpm-tmp.jiiDVK (%build)

You have missing BR:, at least autotools seems to be missing.
Comment 4 Alec Leamas 2013-06-13 03:19:48 EDT
BTW: If this works as it should, the you should have seen a line like this on the console when running fedora-review on tcpcopy:

ERROR: 'mock build failed, see /home/leamas/tmp/FedoraReview/tcpcopy/results/build.log'

Did you get this line?

Note You need to log in before you can comment on or make changes to this bug.