Bug 973991 - quota: list output displays wrong value for "Used" field
quota: list output displays wrong value for "Used" field
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: vpshastry
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 04:38 EDT by Saurabh
Modified: 2016-01-19 01:11 EST (History)
8 users (show)

See Also:
Fixed In Version: v3.4.0.12rhs.beta5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-06-13 04:38:06 EDT
Description of problem:
the mount point has occupied more space than being displayed by the quota list command in the "Used" field"


[root@nfs1 rpms]# gluster volume info
 
Volume Name: dit-rep
Type: Distributed-Replicate
Volume ID: 9f0499fd-39c1-4c94-8d47-b767d6cccf86
Status: Started
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: 10.70.37.180:/rhs/bricks1/d1r1
Brick2: 10.70.37.80:/rhs/bricks1/d1r2
Brick3: 10.70.37.216:/rhs/bricks1/d2r1
Brick4: 10.70.37.139:/rhs/bricks1/d2r2
Brick5: 10.70.37.180:/rhs/bricks1/d3r1
Brick6: 10.70.37.80:/rhs/bricks1/d3r2
Brick7: 10.70.37.216:/rhs/bricks1/d4r1
Brick8: 10.70.37.139:/rhs/bricks1/d4r2
Brick9: 10.70.37.180:/rhs/bricks1/d5r1
Brick10: 10.70.37.80:/rhs/bricks1/d5r2
Brick11: 10.70.37.216:/rhs/bricks1/d6r1
Brick12: 10.70.37.139:/rhs/bricks1/d6r2
Options Reconfigured:
features.limit-usage: /:2GB
features.quota: on
[root@nfs1 rpms]# gluster volume status dit-rep
Status of volume: dit-rep
Gluster process						Port	Online	Pid
------------------------------------------------------------------------------
Brick 10.70.37.180:/rhs/bricks1/d1r1			49152	Y	2857
Brick 10.70.37.80:/rhs/bricks1/d1r2			49152	Y	2647
Brick 10.70.37.216:/rhs/bricks1/d2r1			49152	Y	2491
Brick 10.70.37.139:/rhs/bricks1/d2r2			49152	Y	2530
Brick 10.70.37.180:/rhs/bricks1/d3r1			49153	Y	2866
Brick 10.70.37.80:/rhs/bricks1/d3r2			49153	Y	2656
Brick 10.70.37.216:/rhs/bricks1/d4r1			49153	Y	2500
Brick 10.70.37.139:/rhs/bricks1/d4r2			49153	Y	2539
Brick 10.70.37.180:/rhs/bricks1/d5r1			49154	Y	2875
Brick 10.70.37.80:/rhs/bricks1/d5r2			49154	Y	2665
Brick 10.70.37.216:/rhs/bricks1/d6r1			49154	Y	2509
Brick 10.70.37.139:/rhs/bricks1/d6r2			49154	Y	2548
NFS Server on localhost					2049	Y	2885
Self-heal Daemon on localhost				N/A	Y	2894
NFS Server on 81a6eec0-7a72-4991-b1cc-271ee72a3724	2049	Y	2566
Self-heal Daemon on 81a6eec0-7a72-4991-b1cc-271ee72a372
4							N/A	Y	2562
NFS Server on d90d7051-b2eb-448b-ab85-88519d0ac5aa	2049	Y	2521
Self-heal Daemon on d90d7051-b2eb-448b-ab85-88519d0ac5a
a							N/A	Y	2527
NFS Server on e534091c-cec8-4645-9ce3-bf0008af32fc	2049	Y	2677
Self-heal Daemon on e534091c-cec8-4645-9ce3-bf0008af32f
c							N/A	Y	2682
 
There are no active volume tasks


Version-Release number of selected component (if applicable):
[root@nfs2 ~]# rpm -qa | grep glusterfs
glusterfs-3.4rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4rhs-1.el6rhs.x86_64
glusterfs-server-3.4rhs-1.el6rhs.x86_64
[root@nfs2 ~]# 

cleint,
[root@rhel6 nfs-test]# cat /etc/issue
Red Hat Enterprise Linux Server release 6.4 (Santiago)
Kernel \r on an \m



How reproducible:
always

Steps to Reproduce:
1. create a 6x2 volume, start it.
2. enable quota on the volume
3. gluster volume quota <vol-name> / 2GB
4. mount -t nfs -o vers=3 server-ip:<vol-name> <mount-point>
5. start creating 1000 files each of size 1 MB.
6. gluster volume quota list

Actual results:
On server:-
[root@nfs2 ~]# gluster volume quota dit-rep list
	Path		 Hard-limit	 Soft-limit	 Used	 Available
----------------------------------------------------------------------------------
/                           2GB        80%              184.0MB                1.8GB

On client:-
[root@rhel6 nfs-test]# mount | grep /mnt/nfs-test
10.70.37.80:/dit-rep on /mnt/nfs-test type nfs (rw,vers=3,addr=10.70.37.80)
[root@rhel6 nfs-test]# 
[root@rhel6 nfs-test]# du -sh .
1001M   .
[root@rhel6 nfs-test]# 


Expected results:
the Used file should match, the du output on client.

Additional info:
Comment 3 Saurabh 2013-06-13 04:46:15 EDT
same is the result with the glusterfs mount also,
this time I deleted the earlier data and recreated the data on the glusterfs mount,

client side,
[root@rhel6 glusterfs-test]# du -h .
1001M   .
[root@rhel6 glusterfs-test]# rpm -qa | grep gluster
glusterfs-3.4rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4rhs-1.el6rhs.x86_64
[root@rhel6 glusterfs-test]# 
[root@rhel6 glusterfs-test]# 
[root@rhel6 glusterfs-test]# mount | grep gluster
10.70.37.80:/dit-rep on /mnt/glusterfs-test type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)
[root@rhel6 glusterfs-test]#


on server,
[root@nfs2 ~]# gluster volume quota dit-rep list
	Path		 Hard-limit	 Soft-limit	 Used	 Available
----------------------------------------------------------------------------------
/                           2GB        80%              184.0MB                1.8GB
Comment 5 vpshastry 2013-07-19 08:14:53 EDT
Marker updation is wrong and goes below zero. The temporary fix is in the above link.
Comment 7 Scott Haines 2013-09-23 18:39:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 8 Scott Haines 2013-09-23 18:43:48 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.