Bug 974002 - Run rhc-admin-migrate with --ignore_cartridge_version will make the scalable app cannot work
Run rhc-admin-migrate with --ignore_cartridge_version will make the scalable ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mrunal Patel
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 05:10 EDT by Meng Bo
Modified: 2015-05-14 20:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-24 10:54:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Meng Bo 2013-06-13 05:10:47 EDT
Description of problem:
Create scalable apps on devenv-stage_373, upgrade server to devenv_3355, and do migration with "rhc-admin-migrate --version 2.0.29 --ignore_cartridge_version"

After migration done, visit the scalable app home page, it will redirect to the /haproxy-status/ page. Web gears cannot be detected.

Version-Release number of selected component (if applicable):
devenv-stage_373 to devenv_3355

How reproducible:
always

Steps to Reproduce:
1.Launch devenv-stage_373
2.Create some scalable app on it
3.Do server upgrade
4.Migrate app with option --ignore_cartridge_version

Actual results:
Migration will finish without problem but the scalable app cannot be used any more.

Expected results:
Scalable app should work well after migration with option --ignore_cartridge_version.

Additional info:
It is ok for non-scalable apps.

After that, do migration without --ignore_cartridge_version again, will not save the abnormal scalable apps.
Comment 2 Jianwei Hou 2013-06-17 05:27:04 EDT
Blocked by bug 974965.
After worked around bug 974965, the problem described in this bug is gone. So I can confirm this bug is fixed.
Will move it to verified after bug 974965 is fixed
Comment 3 Jianwei Hou 2013-06-18 03:38:38 EDT
Verified on devenv_3375, the scalable apps work well after migrated with --ignore-cartridge-version option

Note You need to log in before you can comment on or make changes to this bug.