Bug 974006 - /usr/bin/xulrunner points to non-existent directory
/usr/bin/xulrunner points to non-existent directory
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xulrunner (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Horak
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 05:27 EDT by Matěj Cepl
Modified: 2014-06-13 07:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: xulrunner-17.0.7-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:29:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2013-06-13 05:27:24 EDT
Description of problem:
/usr/bin/xulrunner script basically runs

%{_libdir}/xulrunner-%{version}/xulrunner "$@"

(using RPM .spec notation).

Except it doesn't work, because xulrunner package installs into unversioned %{_libdir}/xulrunner directory instead

Version-Release number of selected component (if applicable):
xulrunner-17.0.6-1.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.on command line run xulrunner --help
2.
3.

Actual results:
matej@wycliff: xpi (standalone %)$ xulrunner --help
Error: /usr/lib64/xulrunner-17.0.6/xulrunner not found
       /usr/lib/xulrunner-17.0.6/xulrunner not found

Expected results:
xulrunner presenting some help options
Comment 2 Vera Budikova 2014-02-06 07:11:34 EST
Verification:

Package version: xulrunner-24.2.0-3.el7.x86_64

Steps:
1. xulrunner --help

Result:
xulrunner shows help options
Comment 3 Ludek Smid 2014-06-13 07:29:17 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.