Bug 974007 - remove-brick operation on distribute-replicate volume fails to start when specifying more than one replica pair
remove-brick operation on distribute-replicate volume fails to start when spe...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ravishankar N
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 05:29 EDT by Ravishankar N
Modified: 2014-04-17 07:42 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 07:42:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2013-06-13 05:29:20 EDT
Description of problem:
On a distribute-replicate volume added as storage domain, for VM image store, in RHEV, remove-brick operation was attempted specifying two replica pairs of bricks. But the start failed with message "Bricks not from same subvol for replica"

When a single replica pair of bricks was given, the remove-brick operation started successfully

Refer Bug:923560 for details.
Comment 1 Anand Avati 2013-06-13 22:02:20 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Anand Avati 2013-06-17 05:37:04 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 4 Anand Avati 2013-07-03 06:17:05 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 5 Anand Avati 2013-07-04 08:25:07 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 6 Anand Avati 2013-07-10 08:25:40 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 7 Anand Avati 2013-07-12 05:13:25 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#6) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 8 Anand Avati 2013-07-16 03:05:14 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#7) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 9 Anand Avati 2013-07-19 04:28:58 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#8) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 10 Anand Avati 2013-07-19 09:29:05 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#9) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 11 Anand Avati 2013-07-29 02:28:17 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#10) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 12 Anand Avati 2013-08-05 04:08:47 EDT
REVIEW: http://review.gluster.org/5210 (glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.) posted (#11) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 13 Anand Avati 2013-08-13 10:11:02 EDT
COMMIT: http://review.gluster.org/5210 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 528cbf0ef1b8cbabbab5141df69353d7cf9f59f5
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu Jun 13 14:51:46 2013 +0000

    glusterd: remove-brick:Allow simultaneous removal of multiple subvolumes.
    
    Currently, remove-brick supports removal of only one distributed
    stripe/ replica pair at a time. Fix it to support removal of multiple
    pairs. This is consistent with add-brick behaviour which supports adding
    multiple stripe/replica pairs simultaneously.
    
    Removal is successful irrespective of the order of the bricks given at
    the CLI, as long as the bricks are from the same subvolume(s).
    
    Change-Id: I7c11c1235ce07b124155978b9d48d0ea65396103
    BUG: 974007
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5210
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Krishnan Parthasarathi <kparthas@redhat.com>
Comment 14 Niels de Vos 2014-04-17 07:42:45 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.