Bug 974012 - syslogd sends empty messages when launching instances
syslogd sends empty messages when launching instances
Status: CLOSED WONTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
3.0
Unspecified Unspecified
low Severity low
: ---
: 6.0 (Juno)
Assigned To: RHOS Maint
yeylon@redhat.com
: Automation, MoveUpstream, Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 05:33 EDT by yfried
Modified: 2016-04-26 11:00 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-16 10:31:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yfried 2013-06-13 05:33:50 EDT
Description of problem:
I keep getting this message every time i launch an instance. happens for cirros image and rhel64

message:

Message from syslogd@<HOST> at <TIME> ...
 1>

this happens when an instance goes from BUILD to ACTIVE

Version-Release number of selected component (if applicable):
openstack-nova-compute-2013.1.1-4.el6ost.noarch

How reproducible:
Allinone setup
nova boot

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 2 Russell Bryant 2013-11-14 10:19:28 EST
Note that the default configuration of nova is not to use syslog.  So, unless nova's config has been updated, this isn't coming from nova code.  It's still something we should track down because I'm sure people will wonder what it is and call us about it.  But step 1 is figuring out what process is logging this.
Comment 3 yfried 2014-05-28 00:57:59 EDT
I haven't seen this in Icehouse.
Though because of the vague nature of this bug, I cannot say if this is because it's fixed, masked, or I simply stopped doing whatever it was that caused it
Comment 4 yfried 2014-06-01 04:23:40 EDT
update:
RHOS-4.0 on RHEL-6.5
puddle 2014-04-15.5


I'm seeing this once again, though - much in final number of messages.
This started immediately after I've migrated a VM from computeA to computeB

First, messages started appearing on computeB, and once I've verified migration in GUI, messages appeared on computeA as well


ComputeB (1msg):

Message from syslogd@puma56 at Jun  1 10:02:56 ...
 1>


ComputeA (4msgs):
[root@puma55 ~]# 
Message from syslogd@puma55 at Jun  1 10:47:10 ...
 1>

Message from syslogd@puma55 at Jun  1 10:47:16 ...
 1>

Message from syslogd@puma55 at Jun  1 10:47:21 ...
 1>

Message from syslogd@puma55 at Jun  1 10:47:23 ...
 1>

The setup is available for more debug, should you like to see for yourselves.

controller
[root@puma53 ~]# rpm -qa |grep openstack
openstack-nova-common-2013.2.3-5.el6ost.noarch
openstack-neutron-2013.2.3-4.el6ost.noarch
openstack-selinux-0.1.3-2.el6ost.noarch
openstack-utils-2013.2-3.el6ost.noarch
openstack-neutron-openvswitch-2013.2.3-4.el6ost.noarch
openstack-nova-compute-2013.2.3-5.el6ost.noarch
openstack-ceilometer-compute-2013.2.3-1.el6ost.noarch
openstack-ceilometer-common-2013.2.3-1.el6ost.noarch
openstack-keystone-2013.2.3-3.el6ost.noarch

computeA
[root@puma55 ~]# rpm -qa | grep openstack
openstack-nova-compute-2013.2.3-5.el6ost.noarch
openstack-glance-2013.2.3-1.el6ost.noarch
openstack-selinux-0.1.3-2.el6ost.noarch
openstack-ceilometer-common-2013.2.3-1.el6ost.noarch
openstack-neutron-2013.2.3-4.el6ost.noarch
openstack-nova-common-2013.2.3-5.el6ost.noarch
openstack-ceilometer-compute-2013.2.3-1.el6ost.noarch
openstack-utils-2013.2-3.el6ost.noarch
openstack-neutron-openvswitch-2013.2.3-4.el6ost.noarch


computeB
[root@puma56 ~]# rpm -qa | grep openstack
openstack-nova-common-2013.2.3-5.el6ost.noarch
openstack-neutron-2013.2.3-4.el6ost.noarch
openstack-nova-conductor-2013.2.3-5.el6ost.noarch
openstack-nova-cert-2013.2.3-5.el6ost.noarch
openstack-selinux-0.1.3-2.el6ost.noarch
openstack-utils-2013.2-3.el6ost.noarch
openstack-neutron-openvswitch-2013.2.3-4.el6ost.noarch
openstack-nova-api-2013.2.3-5.el6ost.noarch
openstack-nova-novncproxy-2013.2.3-5.el6ost.noarch
openstack-nova-console-2013.2.3-5.el6ost.noarch
openstack-ceilometer-common-2013.2.3-1.el6ost.noarch
openstack-nova-compute-2013.2.3-5.el6ost.noarch
openstack-nova-scheduler-2013.2.3-5.el6ost.noarch
openstack-ceilometer-compute-2013.2.3-1.el6ost.noarch

Note You need to log in before you can comment on or make changes to this bug.