Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 974031 - openstack-nova: instance in libvirt are not shown with uuid
openstack-nova: instance in libvirt are not shown with uuid
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
unspecified
x86_64 Linux
low Severity medium
: ---
: 6.0 (Juno)
Assigned To: Ryan Hallisey
Ami Jeain
: MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 06:23 EDT by Dafna Ron
Modified: 2016-04-26 18:30 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-31 15:20:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1023865 None None None Never

  None (edit)
Description Dafna Ron 2013-06-13 06:23:47 EDT
Description of problem:

when we run virsh -r list the instances are shown as instance-00000001, instance-00000023 atc. 
to be able to debug problems properly it will help if the virsh doms will appear with the UUID of the instance shown in nova list or at least show the instance virsh when running nova list. 

Version-Release number of selected component (if applicable):

openstack-nova-compute-2013.1.1-4.el6ost.noarch
openstack-packstack-2013.1.1-0.15.dev625.el6ost.noarch
openstack-nova-api-2013.1.1-4.el6ost.noarch
openstack-utils-2013.1-8.el6ost.noarch
libvirt-0.10.2-18.el6_4.5.x86_64

How reproducible:

100%

Steps to Reproduce:
1. build instances 
2. run nova list
3. run virsh -r list

Actual results:

libvirt instances do not show the instance uuid which makes it hard to debug issues. 

Expected results:

we should see the uuid for the libvirt instances domains.  

Additional info:

[root@opens-vdsb /(keystone_admin)]# nova list
+--------------------------------------+-------------------------------------------+---------+---------------------------+
| ID                                   | Name                                      | Status  | Networks                  |
+--------------------------------------+-------------------------------------------+---------+---------------------------+
| 1b1eb170-3bdb-496e-bcaa-2a3cd5078e06 | HAHA-1b1eb170-3bdb-496e-bcaa-2a3cd5078e06 | ACTIVE  | novanetwork=192.168.32.19 |
| 2e19d87f-44ac-4525-bccd-41f2d0350a92 | HAHA-2e19d87f-44ac-4525-bccd-41f2d0350a92 | SHUTOFF | novanetwork=192.168.32.17 |
| 7f4df8e2-77fc-495e-acea-467b039e1ccd | HAHA-7f4df8e2-77fc-495e-acea-467b039e1ccd | SHUTOFF | novanetwork=192.168.32.3  |
| 80fbf669-e8c5-422a-b2ff-90c34e09d8ec | HAHA-80fbf669-e8c5-422a-b2ff-90c34e09d8ec | ACTIVE  | novanetwork=192.168.32.4  |
| 9f0cb489-56d3-4258-93e6-0c927cf70352 | HAHA-9f0cb489-56d3-4258-93e6-0c927cf70352 | ACTIVE  | novanetwork=192.168.32.2  |
| a512a696-13f3-4e48-8154-d8de3ad35af4 | HAHA-a512a696-13f3-4e48-8154-d8de3ad35af4 | SHUTOFF | novanetwork=192.168.32.16 |
| d965ae10-6175-4c57-93f9-47b57c7a2907 | HAHA-d965ae10-6175-4c57-93f9-47b57c7a2907 | ACTIVE  | novanetwork=192.168.32.14 |
| da936d2d-0273-4f47-b6cb-24ea24577317 | HAHA-da936d2d-0273-4f47-b6cb-24ea24577317 | ACTIVE  | novanetwork=192.168.32.15 |
| fa7ea571-a0c1-4cef-9788-ef1e0cf1bf8d | HAHA-fa7ea571-a0c1-4cef-9788-ef1e0cf1bf8d | SHUTOFF | novanetwork=192.168.32.18 |
| 12893599-1418-4cf0-b74d-5f2200418a74 | haha10                                    | ACTIVE  | novanetwork=192.168.32.5  |
+--------------------------------------+-------------------------------------------+---------+---------------------------+


[root@opens-vdsb /(keystone_admin)]# virsh -r list
 Id    Name                           State
----------------------------------------------------
 26    instance-0000003a              running
 27    instance-00000038              running
 28    instance-00000034              running
 29    instance-00000032              running
 30    instance-00000036              running
Comment 2 Stephen Gordon 2014-07-31 15:20:23 EDT
Looks like the LP bug was actually fixed in Icehouse.

Note You need to log in before you can comment on or make changes to this bug.