Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 974043 - ceilometerclient uses suppressed v1 metering API out-of-the-box, so fails with 404
ceilometerclient uses suppressed v1 metering API out-of-the-box, so fails wit...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-ceilometerclient (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 3.0
Assigned To: Jakub Ruzicka
Ami Jeain
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 06:48 EDT by Eoghan Glynn
Modified: 2015-06-04 17:52 EDT (History)
5 users (show)

See Also:
Fixed In Version: python-ceilometerclient-1.0.0-2.el6ost
Doc Type: Bug Fix
Doc Text:
Previously, Ceilometer commands failed with a 404 Error unless the latest metering API was explicitly specified. This has been fixed by using the latest metering API by default, so Ceilometer commands work as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 13:17:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0968 normal SHIPPED_LIVE Red Hat OpenStack 3.0 ("Grizzly") bug fix and enhancement update 2013-06-27 17:14:27 EDT

  None (edit)
Description Eoghan Glynn 2013-06-13 06:48:20 EDT
Description of problem:

The ceilometerclient CLI targets the v1 metering API by default out-of-the-box.

However in RHOS, we use enable_v1_api=false in the distribution config to suppress this API (due to the problematic flask dependency).

So all command fails with 404, unless '--ceilometer-api-version 2' is specified explicitly or alternatively 'export CEILOMETER_API_VERSION=2' is set in the environment.


Version-Release number of selected component (if applicable):

python-ceilometerclient-1.0.0-1.el6ost.noarch


How reproducible:

100%


Steps to Reproduce:
1. ceilometer --debug resource-list 2>&1 | grep curl | awk -F/ '{print $(NF-1)}'


Actual results:
v1


Expected results:
v2


Additional info:

Workaround:
  alias ceilometer='ceilometer --ceilometer-api-version 2'
OR
  export CEILOMETER_API_VERSION=2
Comment 4 Ami Jeain 2013-06-17 10:51:12 EDT
#  ceilometer --debug resource-list 2>&1 | grep curl | awk -F/ '{print $(NF-1)}'
v2
Comment 6 Bruce Reeler 2013-06-20 21:46:58 EDT
Edited Doc Text
Comment 8 errata-xmlrpc 2013-06-27 13:17:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0968.html

Note You need to log in before you can comment on or make changes to this bug.