Bug 974064 - Failing to setup rhevm-reports
Summary: Failing to setup rhevm-reports
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports (Show other bugs)
(Show other bugs)
Version: 3.2.0
Hardware: x86_64 Linux
high
high
Target Milestone: ---
: 3.3.0
Assignee: Sandro Bonazzola
QA Contact: Pavel Stehlik
URL:
Whiteboard: integration
Keywords: ZStream
Depends On:
Blocks: 974528
TreeView+ depends on / blocked
 
Reported: 2013-06-13 11:16 UTC by Kiril Nesenko
Modified: 2015-09-22 13:09 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, uninstalling the reports package caused reinstallations to fail while setting up rhevm-reports. This was because no password was supplied to connect to the reports database. The execExternalCmd command has been updated with the correct PGPASSFILE environment value, allowing execution of database commands.
Story Points: ---
Clone Of:
: 974528 (view as bug list)
Environment:
Last Closed: 2014-01-21 14:54:56 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs (15.45 KB, text/x-log)
2013-06-13 11:16 UTC, Kiril Nesenko
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0035 normal SHIPPED_LIVE rhevm-reports 3.3 bug fix and enhancement update 2014-01-21 19:53:30 UTC
oVirt gerrit 15660 None None None Never

Description Kiril Nesenko 2013-06-13 11:16:11 UTC
Created attachment 760617 [details]
logs

Description of problem:
Failing to setup rhevm-reports

2013-06-13 13:27:59::DEBUG::common_utils::309::root:: cmd = /usr/bin/dropdb -U postgres rhevmreports
2013-06-13 13:28:31::DEBUG::common_utils::314::root:: output = 
2013-06-13 13:28:31::DEBUG::common_utils::315::root:: stderr = dropdb: could not connect to database postgres: fe_sendauth: no password supplied

Version-Release number of selected component (if applicable):
rhevm-reports-3.2.1-2.el6ev.noarch


How reproducible:


Steps to Reproduce:
1. Run rhevm-reports
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Yaniv Lavi 2013-06-13 12:41:07 UTC
This only happens when you uninstall the reports package, then reinstall and run setup.



Yaniv

Comment 4 David Botzer 2013-06-23 14:20:16 UTC
Fixed, 3.3/is2 
I am able to uninstall reports & reinstall and run setup
-- Fails if I delete the rhevmreports DB 
Fixed, 3.3/is2 

Notes: 
1. Reports Portal is unavailable
2. Reinstall of reports Fails if I delete the rhevmreports DB

Comment 5 Charlie 2013-11-28 00:49:42 UTC
This bug is currently attached to errata RHEA-2013:15115. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.

Comment 9 errata-xmlrpc 2014-01-21 14:54:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0035.html


Note You need to log in before you can comment on or make changes to this bug.