Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 974083 - [abrt] qt-creator-2.7.0-1.fc18: __cxxabiv1::__cxa_rethrow: Process /usr/bin/qtcreator was killed by signal 6 (SIGABRT)
[abrt] qt-creator-2.7.0-1.fc18: __cxxabiv1::__cxa_rethrow: Process /usr/bin/q...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: qt-creator (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Itamar Reis Peixoto
Fedora Extras Quality Assurance
abrt_hash:e4e1c8debfe1491a05a239ccefc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 07:56 EDT by 0
Modified: 2013-10-17 17:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 17:52:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (70.15 KB, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: cgroup (125 bytes, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: core_backtrace (1.10 KB, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: dso_list (20.68 KB, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: environ (1.72 KB, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: limits (1.29 KB, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: maps (101.20 KB, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: open_fds (2.74 KB, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details
File: proc_pid_status (942 bytes, text/plain)
2013-06-13 07:56 EDT, 0
no flags Details

  None (edit)
Description 0 2013-06-13 07:56:11 EDT
Description of problem:
1. Install Qt Creator 2.7
2. Install qt5 & qt5-devel packages
3. Setup Qt Creator to use Qt 5
4. In Qt Creator create Qt Quick 2 project and open QML file in designer.

Version-Release number of selected component:
qt-creator-2.7.0-1.fc18

Additional info:
reporter:       libreport-2.1.4
backtrace_rating: 4
cmdline:        /usr/bin/qtcreator
crash_function: __cxxabiv1::__cxa_rethrow
executable:     /usr/bin/qtcreator
kernel:         3.9.4-200.fc18.x86_64
runlevel:       N 5
uid:            1000
xsession_errors: 

Truncated backtrace:
Thread no. 1 (3 frames)
 #5 __cxxabiv1::__cxa_rethrow at ../../../../libstdc++-v3/libsupc++/eh_throw.cc:116
 #6 QEventLoop::exec at kernel/qeventloop.cpp:218
 #7 QCoreApplication::exec at kernel/qcoreapplication.cpp:1221
Comment 1 0 2013-06-13 07:56:16 EDT
Created attachment 760633 [details]
File: backtrace
Comment 2 0 2013-06-13 07:56:20 EDT
Created attachment 760634 [details]
File: cgroup
Comment 3 0 2013-06-13 07:56:24 EDT
Created attachment 760635 [details]
File: core_backtrace
Comment 4 0 2013-06-13 07:56:28 EDT
Created attachment 760636 [details]
File: dso_list
Comment 5 0 2013-06-13 07:56:32 EDT
Created attachment 760637 [details]
File: environ
Comment 6 0 2013-06-13 07:56:36 EDT
Created attachment 760638 [details]
File: limits
Comment 7 0 2013-06-13 07:56:42 EDT
Created attachment 760639 [details]
File: maps
Comment 8 0 2013-06-13 07:56:46 EDT
Created attachment 760640 [details]
File: open_fds
Comment 9 0 2013-06-13 07:56:50 EDT
Created attachment 760641 [details]
File: proc_pid_status
Comment 10 Sandro Mani 2013-10-17 17:52:29 EDT
Since this bug was reported against a now obsolete version of qt-creator, I'm closing this as WONTFIX. Please reopen if the issue still occurs, and preferably file an upstream bug report at [1] and post a link here. Thanks.

[1] https://bugreports.qt-project.org/browse/QTCREATORBUG

Note You need to log in before you can comment on or make changes to this bug.