Bug 974093 - "Don't save password" checkbox doesn't seem to work
"Don't save password" checkbox doesn't seem to work
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libreport (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 08:10 EDT by Kamil Páral
Modified: 2013-06-13 09:03 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 09:03:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2013-06-13 08:10:57 EDT
Description of problem:
In libreport if I check "Don't save password" checkbox while populating Bugzilla credentials, it tries to open a gnome keyring anyway (I don't know if it actually saves the password, but there's no need to touch the keyring, is it?). On LiveCD this results in a dialog "please insert your password for a newly created keyring".

If I select "Don't save password", please don't create a keyring.

Seen with F19 TC3 Live x86_64. It is a bit hard to test now because of bug 974032.
Comment 1 Jakub Filak 2013-06-13 09:03:57 EDT
This has been already discussed here bug #767186 comment #2

If you do not want to struggle with keyring just don't configure anything and continue in reporting and later you will be asked for missing configuration options (see bug #861899 for more details). But this works only for the bugzilla reporter, thus we cannot remove the missing configuration dialogue.

If you do not find this explanation satisfactory please reopen.

Note You need to log in before you can comment on or make changes to this bug.