Bug 974107 - [engine-backend] engine does not support vdsm-versions > 4.10
Summary: [engine-backend] engine does not support vdsm-versions > 4.10
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
(Show other bugs)
Version: 3.3.0
Hardware: x86_64 Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Nobody's working on this, feel free to take it
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-13 12:37 UTC by Elad
Modified: 2015-09-22 13:09 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 13:43:22 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elad 2013-06-13 12:37:46 UTC
Description of problem:
DB should contain higher versions of vdsm than 4.10
vdsm with version that higher than 4.10 could not be added to rhev cluster

Version-Release number of selected component (if applicable):
rhevm-3.2.0-11.29.el6ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. try to add vdsm with higer version than 4.10 (like 4.11)


Actual results:
engine fails to join vdsm to cluster 

Expected results:
DB should be updated to support higer versions of vdsm

Additional info:


engine=# select * from vdc_options where option_name ilike '%version%';
 option_id |           option_name           | option_value  | version
-----------+---------------------------------+---------------+---------
       190 | MinimalETLVersion               | 3.2.0         | general
       223 | OvirtInitialSupportedIsoVersion | 2.5.5         | general
       255 | ProductRPMVersion               | 3.3.0.0       | general
       341 | VdcVersion                      | 3.3.0.0       | general
       304 | SupportedVDSMVersions           | 4.9,4.10,     | general
         1 | BootstrapMinimalVdsmVersion     | 4.9           | general
(6 rows)

Comment 1 Itamar Heim 2013-06-13 13:01:39 UTC
which error did you get?
what does your vdsm getVdsCaps shows for supportedRHEVMs = ['3.0', '3.1', '3.2']?

Comment 2 Elad 2013-06-13 13:03:11 UTC
Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.3.master.el6ev.noarch

Comment 3 Elad 2013-06-13 13:43:22 UTC
Itamar, since my vdsm does not support RHEVM 3.2/3.2, I'm closing the bug as NOTABUG


Note You need to log in before you can comment on or make changes to this bug.