Bug 974165 - beaker-wizard tracebacks on KeyError: 'ispatch'
beaker-wizard tracebacks on KeyError: 'ispatch'
Status: CLOSED DUPLICATE of bug 929190
Product: Beaker
Classification: Community
Component: command line (Show other bugs)
0.12
Unspecified Unspecified
unspecified Severity high (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
:
: 974161 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 10:35 EDT by Tomas Dolezal
Modified: 2014-08-12 00:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-13 19:56:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Dolezal 2013-06-13 10:35:52 EDT
Description of problem:
Traceback appears when fetching certain info from bugzilla.

Version-Release number of selected component (if applicable):
beaker-client-0.12.1-1.el6eng.noarch

How reproducible:
always

Steps to Reproduce:
$ beaker-wizard -b 847339

Actual results:
Contacting bugzilla...
Fetching details for BZ#847339
Examining attachments for possible reproducers
Traceback (most recent call last):
  File "/usr/bin/beaker-wizard", line 9, in <module>
    load_entry_point('bkr.client==0.12.1', 'console_scripts', 'beaker-wizard')()
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 2626, in main
    test = Test(options)
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1089, in __init__
    self.init()
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 2328, in init
    self.testname = Name(self.options)
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1089, in __init__
    self.init()
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1846, in init
    self.bugs.fetchBugDetails()
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1776, in fetchBugDetails
    self.reproducers.find(self.bug)
  File "/usr/lib/python2.6/site-packages/bkr/client/wizard.py", line 1911, in find
    if attachment['ispatch'] == 0 and attachment['isobsolete'] == 0:
KeyError: 'ispatch'

Expected results:
summary appears

Additional info:
Comment 1 Tomas Dolezal 2013-06-13 10:36:33 EDT
*** Bug 974161 has been marked as a duplicate of this bug. ***
Comment 2 Nick Coghlan 2013-06-13 19:56:14 EDT
This has already been fixed and will be included in the upcoming 0.13 release.

*** This bug has been marked as a duplicate of bug 929190 ***

Note You need to log in before you can comment on or make changes to this bug.