Bug 9743 - Russian locale name is stripped by /usr/bin/netscape wrapper
Summary: Russian locale name is stripped by /usr/bin/netscape wrapper
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netscape   
(Show other bugs)
Version: 6.2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-24 10:57 UTC by Leonid Kanter
Modified: 2014-03-17 02:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-25 16:30:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Modified wrapper for testing only (5.96 KB, text/plain)
2000-02-24 18:59 UTC, Leonid Kanter
no flags Details

Description Leonid Kanter 2000-02-24 10:57:50 UTC
You are stripping Russian locale name by netscape wrapper from
"ru_RU.KOI8-R" to "ru". But it's impossible to enter text in Russian in any
input field, including message composer, if LC_CTYPE=ru_RU.KOI8-R is not
set. And we like to see message dates in Russian when LC_TIME is set.
PLEASE PLEASE PLEASE don't strip ru_RU.KOI8-R!

Comment 1 Bill Nottingham 2000-02-24 17:55:59 UTC
Arrgh. Unfortunately, if we leave it like that, the address
book will start exploding if you try to use it.

Comment 2 Bill Nottingham 2000-02-24 17:57:59 UTC
Hm, I suppose we could leave LANG as ru, unset LC_ALL,
and set LC_CTYPE and LC_TIME explicitly; would that
work for you?

Comment 3 Leonid Kanter 2000-02-24 18:58:59 UTC
from modified wrapper's output:

+ unset LC_ALL
+ export LC_CTYPE=ru_RU.KOI8-R
+ LC_CTYPE=ru_RU.KOI8-R
+ export LC_TIME=ru_RU.KOI8-R
+ LC_TIME=ru_RU.KOI8-R
+ locale
LANG=ru
LC_CTYPE=ru_RU.KOI8-R
LC_NUMERIC="ru"
LC_TIME=ru_RU.KOI8-R
LC_COLLATE="ru"
LC_MONETARY="ru"
LC_MESSAGES="ru"

This works.

Comment 4 Leonid Kanter 2000-02-24 18:59:59 UTC
Created attachment 130 [details]
Modified wrapper for testing only

Comment 5 Leonid Kanter 2000-02-25 15:46:59 UTC
I found that problem is not Russian-specific. To see message dates in composer
window in national format, it's necessary to LC_TIME to be set to full name of
directory in /usr/share/locale where compiled LC_TIME is placed. Try to enter
command "LC_ALL=fr date" and "LC_ALL=fr_FR date" and see the difference. The
same for LC_CTYPE - if corresponding compiled locale category is not available,
it's impossible to type non-Latin1 characters. So, please preserve full names
like ru_RU.KOI8-R, uk_UA etc. for at least LC_CTYPE and LC_TIME.

Comment 6 Bill Nottingham 2000-02-25 16:30:59 UTC
Actually, netscape (as of 4.72) seems to no longer write
broken locale settings to preferences.js/liprefs.js, so
it looks like the locale munging can be removed.


Note You need to log in before you can comment on or make changes to this bug.