Bug 974317 - depressing mouse button performs selection instead and click
depressing mouse button performs selection instead and click
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-13 20:14 EDT by Paul Lambert
Modified: 2013-11-27 11:36 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 11:36:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/Xorg.0.log (45.50 KB, text/plain)
2013-06-20 19:32 EDT, Paul Lambert
no flags Details

  None (edit)
Description Paul Lambert 2013-06-13 20:14:48 EDT
Description of problem:  Left mouse click does not get captured or react in real time.  I notice this most when using Firefox but it also occurs on open terminal windows.  Instead of clicking the object it is selecting it.  This results in objects being dragged across the screen.  Sometime it is necessary to click an object multiple times just to get it selected.  Occasionally at the same time the entire interface locks up momentarily.


Version-Release number of selected component (if applicable):
Linux BRSINC-01Fed 3.9.5-201.fc18.x86_64

How reproducible:
Every time I try to use my laptop.  In fact it occurred several times just filling out this bug report

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
I began noticing this about two kernels ago.  There was a specific network manager upgrade that could also be the culprit.  I am suspicious that the cpu is going off to never never land and executing a bundle of noops.  Once it returns the system runs until another mouse click is made.  The computer never crashes.  Whatever the problem, this current combination of kernel, mouse driver and network manager make it just about impossible to use my laptop for anything.
Comment 1 Jarod Wilson 2013-06-18 13:45:05 EDT
kernel-utils isn't a valid component, reassigning.
Comment 2 Paul Lambert 2013-06-19 12:58:00 EDT
I have just updated my system to include the kernel 3.9.6-200.fc18.x86_64.  The mouse button does not work at all using FF or the Gnome desktop.  But, it does work when using vmware to run a Windows VM.
Comment 3 Paul Lambert 2013-06-19 13:00:35 EDT
Fedora no longer works for me.  Is there another Redhat system I can install that is more stable and offers no more than 2 upgrades per year?  I do not have time to debug software that developers do not at least alpha test basic functionality before releasing.
Comment 4 Dave Airlie 2013-06-19 22:22:29 EDT
Jarod,

He mentions a kernel upgrade, so I suspect its kernel bug.

Paul, can you boot older kernels from grub? does it go away?
Comment 5 Paul Lambert 2013-06-20 00:22:28 EDT
Booted kernel 3.9.4-200.fc18.x86_64 which is the oldest I have.

I still experience the same problem though I do get responses on one app.  Here are the test results

1) open FF, position cursor in URL input, double click.  If the mouse was working correctly all the text in the URL input would be selected.  It is not.

2) open the Home directory, double click on a subfolder.  If the mouse was working correctly the subfolder would open and its contents would be displayed.  It is not.

3) using FF logon to gmail.  Open inbox, double click on an email.  This does work correctly as the email that is clicked on does open as expected.

Confusing results that indicate there may have been a subtle change to the mouse software that not all apps are handling correctly.  Or, the subtle change was unintended.
Comment 6 Dave Airlie 2013-06-20 19:04:06 EDT
it sounds like some app is doing something broken to be honest, or firefox has gone wierd.

can you create a new a/c with no settings and reproduce it?

can you also attach /var/log/Xorg.0.log
Comment 7 Paul Lambert 2013-06-20 19:32:24 EDT
Created attachment 763614 [details]
/var/log/Xorg.0.log
Comment 8 Paul Lambert 2013-07-20 21:10:41 EDT
After some upgrades during the past month this problem, though still present, was not as noticeable.  However, after the most recent kernel upgrade, Linux BRSINC-01Fed 3.9.10-200.fc18.x86_64 #1 SMP Sun Jul 14 01:36:53 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux, the problem is much more prevelant but not as severe as originally observed.  The problem appears to be getting mouse clicks, keyboard input and scroll bars to respond in real time when using Firefox.  Originally, I reported that when accessing the file system through the Gnome Desktop there were delays too.  I have not experienced desktop delays this time as reported earlier.  I have experienced similar delays in the virtual network when I run VMware.  (So the problem possibly could be network related) When running XP as a virtual machine and the surfing the web with IE it is very painful, like 9600 baud painful or possibly 4800 baud.  This needs immediate attention or I will be getting my Xmas gift in July this year.  A new Mac as just typing in this short comment on Fedora has required 10 minutes.
Comment 9 Justin M. Forbes 2013-10-18 17:07:36 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 10 Paul Lambert 2013-10-18 20:27:50 EDT
Since upgrading to Fedora 19 I not experienced this problem. Ok with me to close this bug as subsequent releases has fixed it.

Note You need to log in before you can comment on or make changes to this bug.