Bug 97435 - gaim doesn't appear to handle http_proxy var correctly
gaim doesn't appear to handle http_proxy var correctly
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: gaim (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Reed
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-15 15:13 EDT by Ronan Waide
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version: 0.75-0.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-03 10:20:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronan Waide 2003-06-15 15:13:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
With the following in my environment:

http_proxy=http://proxy:8080

gaim attempts to connect to a proxy server at port 8080 but with no address. It
also writes garbage into the proxy section of its config file.

Version-Release number of selected component (if applicable):
gaim-0.59.8-0

How reproducible:
Always

Steps to Reproduce:
1. set http_proxy variable in your environment to http://proxy:8080
2. remove proxy specification from .gaimrc
3. start gaim
    

Actual Results:  Gaim starts up with error messages indicating that it can't
connect to the proxy. Bringing up the Options dialog, the proxy port is filled
in but the host field is empty. On quitting, there is garbage in the proxy
section in .gaimrc.

Expected Results:  As far as I am aware, http://proxy:8080 is the correct format
for the http_proxy var. Possibly what gaim is expecting is the HTTP_PROXY
format, which is (again, as far as I'm aware) proxy:8080, i.e. the connection
protocol is not specified.

Additional info:

I do not know where or if there are standards for the http_proxy env var. The
above is something I looked up a long, long time ago and I can no longer recall
where it originated. Other proxy-using tools such as wget seem happy with the
format I'm using.
Comment 1 Mark Doliner 2004-05-02 17:31:24 EDT
This appears to be fixed for me in Gaim 0.77.  It looks like Red Hat 9
updates has a Gaim 0.75 RPM, I believe it is fixed in 0.75, as well.

And AFIK, there are no extremely official standards for proxy
environmental variables.  It looks like Gaim will recognize the following:
HTTP_PROXY
http_proxy
HTTPPROXY
HTTP_PROXY_PORT
http_proxy_port
HTTPPROXYPORT
HTTP_PROXY_USER
http_proxy_user
HTTPPROXYUSER
HTTP_PROXY_PASS
http_proxy_pass
HTTPPROXYPASS
Comment 2 Ronan Waide 2004-05-03 10:20:35 EDT
Granted there are no official standards; however, there does seem to
be a fairly widely-accepted de facto standard. Anyway, the bug does
indeed appear to be fixed. Cheers!

Note You need to log in before you can comment on or make changes to this bug.