Bug 97437 - Please enable --with-thread
Please enable --with-thread
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pygtk2 (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-15 16:39 EDT by Noa Resare
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.99.16-1
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-04 20:34:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noa Resare 2003-06-15 16:39:42 EDT
Description of problem:

It would be nice to be able to use pygtk from Threaded applications. My tests
indicate that threading works ok and at the very least it doesn't break single
threaded apps.

Version-Release number of selected component (if applicable):
pygtk2-1.99.14-4

How reproducible:
always

Steps to Reproduce:
$ python
>>> import gtk
>>> gtk.threads_init()
    
Actual results:
Traceback (most recent call last):
  File "<stdin>", line 1, in ?
RuntimeError: pygtk threading disabled at compile time

Expected results:


Additional info:
Who knows, this change might also improve interactivity in anaconda :P
Comment 1 Noa Resare 2003-07-04 20:34:13 EDT
Seems to be fixed in rawhide. Thanks!

Note You need to log in before you can comment on or make changes to this bug.