This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 974393 - BVT: Validation failed for negative testing for volume-set option "rpc-auth-allow"
BVT: Validation failed for negative testing for volume-set option "rpc-auth-a...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Kaushal
Lalatendu Mohanty
:
Depends On: 977246
Blocks: 974408
  Show dependency treegraph
 
Reported: 2013-06-14 03:00 EDT by Lalatendu Mohanty
Modified: 2013-09-23 18:43 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lalatendu Mohanty 2013-06-14 03:00:29 EDT
Description of problem:

Validation failed for negative testing for volume-set option "rpc-auth-allow" i.e. the invalid argument is available in volume info output

Version-Release number of selected component (if applicable):


How reproducible:
frequently

Steps to Reproduce:

Running 'gluster volume set volume-set rpc-auth-allow 134.2525.332..2' (Expected 1, got 0)
:: [ 21:26:33 ] ::  Executing volume info for validation
:: [   FAIL   ] :: Validation of set option rpc-auth-allow in volume info is Failed 
'048cf5da-43ce-4514-b1db-b92bc8e3be90'
volset-negative-test-rpc-auth-allow- result: FAIL

Actual results:


Expected results:


Additional info:
Comment 2 Kaushal 2013-06-20 02:02:09 EDT
Without the double '.'s the given address is a valid hostname. Not catching the double '.' is a bug.
Comment 3 Kaushal 2013-06-24 03:40:52 EDT
Patch under review at https://code.engineering.redhat.com/gerrit/9216
Comment 4 Lalatendu Mohanty 2013-07-11 05:35:01 EDT
Verified that the bug works fine with nightly build glusterfs-3.4.0.12rhs.beta3-1373473979.el6.x86_64.rpm
Comment 5 Scott Haines 2013-09-23 18:39:51 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:43:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.