Bug 97442 - RPM segfaults when /etc/nsswitch.conf has ldap before files
RPM segfaults when /etc/nsswitch.conf has ldap before files
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-15 18:48 EDT by Daniel Hokka Zakrisson
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-19 08:58:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Hokka Zakrisson 2003-06-15 18:48:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
I just recently setup LDAP authentication in my network (using authconfig).
After a while, I realized that for users that existed in /etc/passwd and
/etc/shadow, it wouldn't use LDAP. Since I always wanted it to use LDAP, I
changed /etc/nsswitch.conf manually to have
passwd: ldap files
shadow: ldap files
group: ldap files
Since I made that change, I can no longer upgrade, install or erase RPMs. It
always throws a segmentation fault at me.

Version-Release number of selected component (if applicable):
rpm -4.1-1.06

How reproducible:
Always

Steps to Reproduce:
1. Make the changes described above to /etc/nsswitch.conf
2. Run a rpm command with either -i, -U or -e.
    

Actual Results:  Segmentation fault

Additional info:

I have been able to reproduce this on all my machines, all having RedHat 8.0
installed. They all have different types of processors (Celeron, Pentium 4,
Pentium 2 and Via Cyrix).
Comment 1 Jeff Johnson 2003-06-19 08:58:55 EDT
If you want to use LDAP, then you need to insure that
nscd is running
    service nscd start
to avoid a linkage problem that affects statically linked binaries
/bin/rpm.

Note You need to log in before you can comment on or make changes to this bug.