Bug 974420 - Kernel 3.9.5 locks up when Qemu/KVM is started
Kernel 3.9.5 locks up when Qemu/KVM is started
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 03:41 EDT by Zoltan Boszormenyi
Modified: 2013-09-19 08:56 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 08:56:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel BUGs for the first lockup (15.22 KB, text/plain)
2013-06-14 03:42 EDT, Zoltan Boszormenyi
no flags Details
general protection faults for the second lockup (40.85 KB, text/plain)
2013-06-14 03:43 EDT, Zoltan Boszormenyi
no flags Details
Kernel BUGs with kernel-3.9.6-301.4.fc19.x86_64 (5.53 KB, text/plain)
2013-06-20 02:41 EDT, Zoltan Boszormenyi
no flags Details

  None (edit)
Description Zoltan Boszormenyi 2013-06-14 03:41:10 EDT
Description of problem:

After yesterday's upgrades for Fedora 19 beta which included kernel 3.9.5-301 and qemu 1.4.2-3, I get lockups soon after I have started a VM. When it first happened, I have reset the computer and tried it again, this time without Firefox, Thunderbird and skype running.

My computer has an 8-core AMD FX-8120 CPU with 16GB memory and the VM guest is CentOS 5.9, 8 CPUs are assigned to it together with 2GB memory. The lockup happends when it tries to switch to "graphics mode" in the guest and starting up X and GDM.

The VM and the computer is completely usable with the previous kernel 3.9.4-301.

The lockup has the attached traces in the syslog for the two lockups.

Version-Release number of selected component (if applicable):

# rpm -q kernel
kernel-3.9.4-300.fc19.x86_64
kernel-3.9.4-301.fc19.x86_64
kernel-3.9.5-301.fc19.x86_64

How reproducible:

Two out of two attempts.

Steps to Reproduce:
1.
2.
3.

Actual results:

Computed locks up.

Expected results:

No lock up.

Additional info:
Comment 1 Zoltan Boszormenyi 2013-06-14 03:42:05 EDT
Created attachment 761126 [details]
Kernel BUGs for the first lockup
Comment 2 Zoltan Boszormenyi 2013-06-14 03:43:02 EDT
Created attachment 761127 [details]
general protection faults for the second lockup
Comment 3 jcpowermac 2013-06-18 13:27:58 EDT
I also had a similar issue, but kernel panic was with a Windows 7 KVM guest.  In my testing I just started the guest with "virsh start Windows7" and within the boot process the kernel will panic.  Since this is my machine for work I just returned to 3.9.4-200.

# rpm -q kernel
kernel-3.9.2-200.fc18.x86_64
kernel-3.9.4-200.fc18.x86_64
kernel-3.9.5-201.fc18.x86_64

Hardware:
MB GIGABYTE GA-990XA-UD3 R
AMD|8-CORE FX-8120
VGA SAPPHIRE|100315L HD6850 R

I don't have the logs from my event.  I would be willing to assist if someone provides the details how to retrieve the panic log.
Comment 4 Andrew Jones 2013-06-19 04:04:59 EDT
(In reply to jcpowermac from comment #3)
> I also had a similar issue, but kernel panic was with a Windows 7 KVM guest.
> In my testing I just started the guest with "virsh start Windows7" and
> within the boot process the kernel will panic.  Since this is my machine for
> work I just returned to 3.9.4-200.

This might be a separate issue and possibly a dup of bug 975065. It would be good to confirm/deny with a backtrace though.

> I don't have the logs from my event.  I would be willing to assist if
> someone provides the details how to retrieve the panic log.

Generally the backtrace will make it to the primary console of the host, particularly if that's a simple serial console. Otherwise you can look into setting up kdump to get the entire core, and then grabbing the backtrace from that.
Comment 5 Josh Boyer 2013-06-19 08:34:59 EDT
Please test this scratch build when it completes:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5520279
Comment 6 Zoltan Boszormenyi 2013-06-20 02:41:25 EDT
Created attachment 763275 [details]
Kernel BUGs with kernel-3.9.6-301.4.fc19.x86_64

Upgrading to kernel-3.9.6-301.4.fc19.x86_64 from koji didn't help.
Same lockup at the same time when KVM is getting to start up GDM in the CentOS 5.9 guest.
Comment 7 Josh Boyer 2013-06-20 08:49:18 EDT
Hm.  Looking at your latest attachment, that seems to be a radeon issue.  Here's another scratch build for you to try if you'd like, but I'm not convinced it's the same issue we're chasing in the other bugs.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5523794
Comment 8 Josh Boyer 2013-09-18 16:48:45 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 9 Zoltan Boszormenyi 2013-09-19 08:56:19 EDT
I should have closed this bug, it was fixed with the kernel upgrade to 3.10.x.

Note You need to log in before you can comment on or make changes to this bug.