This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 974447 - List the available subscriptions for a distributor failed in cli
List the available subscriptions for a distributor failed in cli
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.0.1
x86_64 Linux
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 04:16 EDT by Tazim Kolhar
Modified: 2014-06-19 15:07 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 16:26:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-06-14 04:16:34 EDT
Description of problem:
List the available subscriptions for  a distributor failed in cli

Version-Release number of selected component (if applicable):
# rpm -qa | grep katello
signo-katello-0.0.9-1.el6.noarch
katello-headpin-1.4.2-1.git.638.2148be1.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-cli-1.4.2-1.git.90.6c7a175.el6.noarch
katello-cli-common-1.4.2-1.git.90.6c7a175.el6.noarch
katello-glue-candlepin-1.4.2-1.git.638.2148be1.el6.noarch
katello-configure-1.4.3-1.git.62.f050662.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.2-1.git.638.2148be1.el6.noarch
katello-selinux-1.4.3-1.git.4.99dc194.el6.noarch
katello-common-1.4.2-1.git.638.2148be1.el6.noarch
katello-headpin-all-1.4.2-1.git.638.2148be1.el6.noarch
katello-repos-1.4.2-1.el6.noarch


How reproducible:
# yum install -y katello-headpin-all
# katello-configure --user-pass=****

Steps to Reproduce:
1.# headpin -u admin -p **** distributor subscriptions --name test_dis --org test
Couldn't find system ''

2.# headpin -u admin -p **** distributor subscriptions --name test_dis --org test --available
wrong number of arguments (3 for 0)

3.

Actual results:
Cannot list the available subscriptions for created distributor 

Expected results:
List of all available subscriptions is displayed


Additional info:
Comment 1 RHEL Product and Program Management 2013-06-14 04:25:59 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 4 Bryan Kearney 2014-03-26 16:26:11 EDT
distributor has not been implemented in hammer, closing this.

Note You need to log in before you can comment on or make changes to this bug.