Bug 974454 - uninstall of libvirt doesnt destry virbr0
uninstall of libvirt doesnt destry virbr0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 04:26 EDT by Mohammed Arafa
Modified: 2013-06-18 09:10 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 09:10:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Arafa 2013-06-14 04:26:36 EDT
Description of problem:
uninstall of libvirt doesnt destry virbr0

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1.yum erase libvirt*
2.ifconfig | grep virbr0
3.

Actual results:
virbr0 found

Expected results:
virbr0 not found

Additional info:
Comment 1 Laine Stump 2013-06-14 11:00:25 EDT
Just as libvirt can be stopped and restarted while a guest is running with no disruption to the guest or networks, it can also be uninstalled and reinstalled while there are guests running with no disruption. Doing a forced delete of the bridges that had been created by libvirt would cause that latter convenience functionality to break.

Note that once the host is rebooted, the bridge device will no longer exist.

I'm inclined to close this as WONTFIX, but want to see some other opinions first.
Comment 2 Kashyap Chamarthy 2013-06-15 04:08:32 EDT
(In reply to Laine Stump from comment #1)
> Just as libvirt can be stopped and restarted while a guest is running with
> no disruption to the guest or networks, it can also be uninstalled and
> reinstalled while there are guests running with no disruption. Doing a
> forced delete of the bridges that had been created by libvirt would cause
> that latter convenience functionality to break.
> 
> Note that once the host is rebooted, the bridge device will no longer exist.
> 
> I'm inclined to close this as WONTFIX, but want to see some other opinions
> first.

Agreed with the above comment. FWIW, I've did many re-installs where the default bridge device (virbr0) was still up, and guests were running.
Comment 3 Dave Allan 2013-06-18 09:10:40 EDT
(In reply to Laine Stump from comment #1)
> Just as libvirt can be stopped and restarted while a guest is running with
> no disruption to the guest or networks, it can also be uninstalled and
> reinstalled while there are guests running with no disruption. Doing a
> forced delete of the bridges that had been created by libvirt would cause
> that latter convenience functionality to break.
> 
> Note that once the host is rebooted, the bridge device will no longer exist.
> 
> I'm inclined to close this as WONTFIX, but want to see some other opinions
> first.

I agree that this is behavior by design and shouldn't be changed.  As you point out, the bridge will disappear when the host is rebooted, so it's not left around permanently.

Note You need to log in before you can comment on or make changes to this bug.