Bug 974460 - Should not search keywords in the page source code.
Should not search keywords in the page source code.
Status: CLOSED WONTFIX
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity low
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 04:38 EDT by Yujie Zhang
Modified: 2015-05-14 21:28 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-18 18:28:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2013-06-14 04:38:07 EDT
Description of problem:

Tried to search "megashift" using the search form at the top of home page, and get result including:

OpenShift Online Pricing

    ... { background-color: #f9f9f9; } section.pricing .plans .megashift { background-color: #ececec; z-index: 2; } section.pricing .plans ... ul.lead { margin-top: 20.5px; } section.pricing .plans .megashift h2.name { border-bottom: 2px solid #f9f9f9; font-size: 34px; } ...

Searched another keyword like "background-color", also got result like:

 Enterprise Platform as a Service

    .path-option { background-color: #f2f3f4; box-shadow: 0 0 1px rgba(0, 0, 0, 0.25) inset; ... { margin: 30px 0 0; } } .path-option:hover { background-color: #FAFBFC; } .webinar-blocks { overflow: ...

Found that, it will not only search keyword in the content of pages, it will also search the code of pages.

Version-Release number of selected component (if applicable):
devenv_3360
PROD

How reproducible:
always

Steps to Reproduce:
1.Input keyword like "megashift" or "background-color" to the search form at the top of the home page
2.
3.

Actual results:

Got search result including the code of pages.

Expected results:

Should not get result including the code of pages.

Additional info:
Comment 1 Jordan Liggitt 2013-06-14 10:53:56 EDT
Would require re-doing how inline css is done for drupal pages. We could use something like https://drupal.org/project/css to separate css from page content
Comment 2 Clayton Coleman 2013-06-18 18:28:58 EDT
I'm just going to mark this as won't fix, because it's too fundamental to how drupal works for us to be invested in changing it.

Note You need to log in before you can comment on or make changes to this bug.