Bug 974520 - Attempt to create application fails with Cgroups controller not found for: cpu.cfs_quota_us
Attempt to create application fails with Cgroups controller not found for: cp...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krishna Raman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 06:46 EDT by Jan Pazdziora
Modified: 2015-05-14 19:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:46:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2013-06-14 06:46:57 EDT
Description of problem:

I've installed OpenShift Origin nightly on Fedora 19 using the puppet method. When I try to create the application, either via rhc or via console WebUI, the application does not get created and the operation fails with error message

   Cgroups controller not found for: cpu.cfs_quota_us
   
Version-Release number of selected component (if applicable):

OpenShift Origin nightly on Fedora 19 as of today.

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install OpenShift Origini nightly on Fedora 19.
2. Run rhc setup.
3. Run rhc create-app -n test -a perlx -t perl-5.16

Actual results:

Application Options
-------------------
  Namespace:  test
  Cartridges: perl-5.16
  Gear Size:  default
  Scaling:    no

Creating application 'perlx' ... Cgroups controller not found for: cpu.cfs_quota_us

Expected results:

No error.

Additional info:
Comment 1 Hiro Asari 2013-06-14 12:37:40 EDT
Assigning to Krishna, since it seems Fedora-specific.
Comment 2 Krishna Raman 2013-12-09 15:45:55 EST
Tracked this down to a Kernel issue which has been fixed in Fedora.
Comment 3 Meng Bo 2013-12-11 01:09:38 EST
Perl app can be created successfully on Fedora 19 Origin build. (https://mirror.openshift.com/pub/origin-server/nightly/fedora-19/latest/x86_64/)

Package:
openshift-origin-cartridge-perl-1.17.0-1.git.60.dec301c.fc19.noarch

# rhc app create perl2 perl-5 --no-git
Using perl-5.16 (Perl 5.16) for 'perl-5'

Application Options
-------------------
Domain:     bmeng
Cartridges: perl-5.16
Gear Size:  default
Scaling:    no

Creating application 'perl2' ... done


Waiting for your DNS name to be available ... done

Your application 'perl2' is now available.

  URL:        http://perl2-bmeng.example.com/
  SSH to:     52a801076892df0014000084@perl2-bmeng.example.com
  Git remote: ssh://52a801076892df0014000084@perl2-bmeng.example.com/~/git/perl2.git/

Run 'rhc show-app perl2' for more details about your app.
Comment 4 Jan Pazdziora 2013-12-11 01:38:35 EST
(In reply to Meng Bo from comment #3)
> Perl app can be created successfully on Fedora 19 Origin build.
> (https://mirror.openshift.com/pub/origin-server/nightly/fedora-19/latest/
> x86_64/)

How did you install the build?
Comment 5 Meng Bo 2013-12-11 02:03:54 EST
Hi Jan,

I installed the origin on Fedora 19 by following the guide here.
http://openshift.github.io/documentation/oo_deployment_guide_puppet.html
Comment 6 Jan Pazdziora 2013-12-19 01:11:47 EST
Thanks. I confirm that on Fedora 19 where I don't hit bug 984575, the cpu.cfs_quota_us bug is no longer present.

Note You need to log in before you can comment on or make changes to this bug.