Bug 974608 - Panic on HP BL460c G1 with 3.8 debug kernel
Panic on HP BL460c G1 with 3.8 debug kernel
Status: CLOSED ERRATA
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: realtime-kernel (Show other bugs)
Development
x86_64 Linux
unspecified Severity high
: 2.4
: ---
Assigned To: John Kacur
MRG Quality Engineering
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 11:02 EDT by Clark Williams
Modified: 2013-10-01 12:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: acpi_glb_hardware_lock was converted to sleeping spinlock (rt_mutex_t) by RT patchset Consequence: Panic due to sleeping in atomic context Fix: Convert back to raw_spinlock_t Result: No panic, correct operation.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 12:43:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Boot log of kernel panic (152.06 KB, text/plain)
2013-06-14 11:02 EDT, Clark Williams
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 59631 None None None Never

  None (edit)
Description Clark Williams 2013-06-14 11:02:10 EDT
Created attachment 761313 [details]
Boot log of kernel panic

Description of problem:
Panic observed on debug kernel running on HP BL460c G1

Version-Release number of selected component (if applicable):
kernel-rt-3.8.13-rt10.4.el6rt.x86_64.debug

beaker job: https://beaker.engineering.redhat.com/jobs/434497
Comment 1 John Kacur 2013-06-14 13:26:44 EDT
Steven Rostedt suggests 3de16f6802b0df5eedaf3042800e289154f78e7b
so, forward porting that.
Comment 2 Beth Uptagrafft 2013-06-19 09:53:50 EDT
Sucessfully re-ran the tier1 tests on all kernel variants using 3.8.13-rt11.6, which contians this patch. No panics.

See beaker job: https://beaker.engineering.redhat.com/jobs/436875
Comment 6 errata-xmlrpc 2013-10-01 12:43:47 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1398.html

Note You need to log in before you can comment on or make changes to this bug.