Bug 97461 - GCC internal error -> segfault with '%zd' format conversion (C++)...
Summary: GCC internal error -> segfault with '%zd' format conversion (C++)...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-06-16 10:30 UTC by Daniel J Blueman
Modified: 2007-04-18 16:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-03 23:35:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel J Blueman 2003-06-16 10:30:06 UTC
Description of problem:
when compiling C++ code with the '%zd' format specifier, the compiler crashes.

$ cat test.cc
#include <stdio.h>

int main(void) {
	printf("output is %zd", 123);
}

$ gcc test.cc -o test -Wall
test.cc: In function `int main ()':
test.cc:4: Internal error: Segmentation fault.
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.

Version-Release number of selected component (if applicable):

gcc-2.96-113
gcc-c++-2.96-113

How reproducible:

Every time.

Steps to Reproduce:
1. create small test program (above)
2. compile as above
    
Actual results:
compiler crash

Expected results:
successful compilation

Comment 1 Daniel J Blueman 2003-06-16 10:33:36 UTC
This occurs due to the format conversion checking due to -Wformat (within -Wall)

Comment 2 Richard Henderson 2004-10-03 23:35:44 UTC
Fixed in gcc-3.2.3-20.


Note You need to log in before you can comment on or make changes to this bug.