Bug 974619 - Screen command does not work on openshift
Screen command does not work on openshift
Status: CLOSED UPSTREAM
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 11:52 EDT by Alexander Bätz
Modified: 2015-05-14 19:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 15:02:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Bätz 2013-06-14 11:52:19 EDT
Description of problem:

any call to the screen command fails with "LoginName to long - sorry"

How reproducible:

try to start something in a screen

Steps to Reproduce:
1. ssh to openshift gear
2. try to execute any command with screen ( screen "echo test" )

Actual results:

command is not executed
error message: LoginName too long - sorry.

Expected results:
start screen

Additional info:
known screen bug. see http://lists.gnu.org/archive/html/screen-devel/2011-05/msg00000.html
Comment 1 Mrunal Patel 2013-06-14 15:23:43 EDT
This is an upstream issue: http://savannah.gnu.org/bugs/?21653
Comment 2 Fotios Lindiakos 2013-06-14 15:46:31 EDT
Even if that upstream issue is fixed, we will also hit another bug because $HOME is too long. We might want to consider offering tmux. We could add a helper in rhcsh for screen that tells the user to use tmux instead.

Note You need to log in before you can comment on or make changes to this bug.