Bug 974622 - expect gives error "write() failed to write anything - will sleep(1) and retry..." upon disconnection
expect gives error "write() failed to write anything - will sleep(1) and retr...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: expect (Show other bugs)
5.9
All Linux
unspecified Severity low
: rc
: ---
Assigned To: Vitezslav Crhonek
BaseOS QE - Apps
:
Depends On:
Blocks: 1002709
  Show dependency treegraph
 
Reported: 2013-06-14 12:29 EDT by Ken Booth
Modified: 2013-12-18 19:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-06 21:47:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Booth 2013-06-14 12:29:41 EDT
Description of problem:
  When disconnecting a session, expect reports the following error
write() failed to write anything - will sleep(1) and retry...
it then waits 1 second and exits continues normally.

Version-Release number of selected component (if applicable):
RHEL 5 only - expect 5.43

How reproducible:
100%

Steps to Reproduce:
1. Use the following expect script

#!/usr/bin/expect -d 

spawn telnet <IP address>
expect {
	-re "login:" {
	send "<dummy login>\r"
	}
}
expect {
	-re "Password:" {
	send "<dummy passwd>\r"
	}
}
interact

2. once expect has given you an interactive prompt on the remote server type "exit"

Actual results:
write() failed to write anything - will sleep(1) and retry...
then 1 second later expect exits

Expected results:
expect exits immediately

Additional info:
Fixed in expect 5.45
Fixed in RHEL6 all versions
Comment 1 RHEL Product and Program Management 2013-09-13 07:48:00 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Andrius Benokraitis 2013-10-06 21:47:52 EDT
This Bugzilla has been reviewed by Red Hat and is not planned on being addressed in Red Hat Enterprise Linux 5, and therefore will be closed. If this bug is critical to production systems, please contact your Red Hat support representative and provide sufficient business justification.

Note You need to log in before you can comment on or make changes to this bug.