Bug 974703 - Installation process detaches part of Software RAID array when installing from USB drive
Installation process detaches part of Software RAID array when installing fro...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-14 17:28 EDT by markm
Modified: 2013-06-15 06:25 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-15 06:25:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/anaconda/anaconda.log (35.72 KB, text/x-log)
2013-06-14 18:22 EDT, markm
no flags Details
/var/log/anaconda/anaconda.storage.log (193.72 KB, text/x-log)
2013-06-14 18:22 EDT, markm
no flags Details
/var/log/anaconda/anaconda.program.log (38.08 KB, text/x-log)
2013-06-14 18:22 EDT, markm
no flags Details
/var/log/anaconda/syslog (134.91 KB, text/plain)
2013-06-14 18:23 EDT, markm
no flags Details

  None (edit)
Description markm 2013-06-14 17:28:12 EDT
Description of problem:

System configuration:
sda - 512GB SSD (new, replaced older 128GB)
sdb - 1TB HDD, part of raid array
sdc - 1TB HDD, part of raid array
sdd - 1TB HDD, part of raid array
sde - 1TB HDD, part of raid array

During installation (from USB drive) disk utility mounts:
usb drive as sda
sda as sdb
and so on...

after installation is completed, when I've checked my raid array, it displayed "DEGRADED" and sdb drive was detached from the array.

Version-Release number of selected component (if applicable):

Fedora-19BETA installation dvd

How reproducible:

Tried two times, same issue happened

Steps to Reproduce:
1. Start fresh installation on system with software raid array attached
2. Go to partitioning

Actual results:

installation drive shows up as /dev/sda... while it shouldn't be there

Expected results:

installation usb drive not to shop up on the available devices list

Additional info:
Comment 1 David Lehman 2013-06-14 17:34:20 EDT
Please attach the following files:

 /var/log/anaconda/anaconda.log
 /var/log/anaconda/anaconda.storage.log
 /var/log/anaconda/anaconda.program.log
 /var/log/anaconda/syslog

Thanks.
Comment 2 markm 2013-06-14 18:22:02 EDT
Created attachment 761449 [details]
/var/log/anaconda/anaconda.log
Comment 3 markm 2013-06-14 18:22:33 EDT
Created attachment 761450 [details]
/var/log/anaconda/anaconda.storage.log
Comment 4 markm 2013-06-14 18:22:59 EDT
Created attachment 761451 [details]
/var/log/anaconda/anaconda.program.log
Comment 5 markm 2013-06-14 18:23:20 EDT
Created attachment 761452 [details]
/var/log/anaconda/syslog
Comment 6 David Lehman 2013-06-14 19:26:26 EDT
What you have is an mdarray comprised of a partition on each of sdb,sdc,sdd,sde named Stefan:3.

What you did during disk selection was de-select sdb,sdc,sdd,sde, which means your raid array will not be visible since you've excluded the disks it resides on from the installation.

The only disk modified in any way by the installer is sda (your SSD) since it is the only disk you selected to be used during installation. It does not appear to be the source of the installation media.

It looks to me like sdf is the source for the installation media. Did it appear in the disk list?
Comment 7 markm 2013-06-15 06:25:13 EDT
Actually, it's my fault - I've just attempted to recreate the process.
I've used CentOS CD to partition the SSD before installation with usb drive attached - this is where my disk got detached.

Sorry for the bug report, my fault, should have not installed os late in the night :)

Note You need to log in before you can comment on or make changes to this bug.