Bug 974806 - ACPI WARNING: at mm/page_alloc.c:2387 __alloc_pages_nodemask+0x8f8/0xae0()
ACPI WARNING: at mm/page_alloc.c:2387 __alloc_pages_nodemask+0x8f8/0xae0()
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:6668a473ea1be18cb5789b51d0a...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-15 23:36 EDT by Steven Ramacher
Modified: 2015-03-23 09:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:59:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (56.39 KB, text/plain)
2013-06-15 23:37 EDT, Steven Ramacher
no flags Details

  None (edit)
Description Steven Ramacher 2013-06-15 23:36:49 EDT
Description of problem:
I want sure how this happened.

Additional info:
reporter:       libreport-2.1.4
WARNING: at mm/page_alloc.c:2387 __alloc_pages_nodemask+0x8f8/0xae0()
Hardware name: hp workstation xw6200
Modules linked in:
Pid: 1, comm: swapper/0 Not tainted 3.9.5-201.fc18.x86_64 #1
Call Trace:
 [<ffffffff8105ef85>] warn_slowpath_common+0x75/0xa0
 [<ffffffff8105efca>] warn_slowpath_null+0x1a/0x20
 [<ffffffff8113d7b8>] __alloc_pages_nodemask+0x8f8/0xae0
 [<ffffffff8113d03a>] ? __alloc_pages_nodemask+0x17a/0xae0
 [<ffffffff8137eaec>] ? acpi_ex_do_logical_op+0x167/0x167
 [<ffffffff8138e904>] ? acpi_ut_repair_name+0x2d/0x7d
 [<ffffffff8117b8aa>] alloc_page_interleave+0x3a/0x90
 [<ffffffff8117c0c5>] alloc_pages_current+0x115/0x190
 [<ffffffff8113830a>] __get_free_pages+0x2a/0x80
 [<ffffffff81187b69>] kmalloc_order_trace+0x39/0xb0
 [<ffffffff81187da0>] __kmalloc+0x1c0/0x250
 [<ffffffff8137a72d>] acpi_os_allocate+0x25/0x27
 [<ffffffff8137a953>] acpi_ex_load_op+0xca/0x225
 [<ffffffff8137cdd4>] acpi_ex_opcode_1A_1T_0R+0x2a/0x4d
 [<ffffffff81375734>] acpi_ds_exec_end_op+0xd4/0x3f4
 [<ffffffff813869d4>] acpi_ps_parse_loop+0x520/0x580
 [<ffffffff813874ef>] acpi_ps_parse_aml+0x96/0x27b
 [<ffffffff81387d5b>] acpi_ps_execute_method+0x1cb/0x27c
 [<ffffffff8138252b>] acpi_ns_evaluate+0xc3/0x1ad
 [<ffffffff8138527e>] acpi_evaluate_object+0x120/0x22c
 [<ffffffff81654ee8>] ? acpi_processor_set_pdc+0xc3/0x1b9
 [<ffffffff81654fb8>] acpi_processor_set_pdc+0x193/0x1b9
 [<ffffffff81d3716f>] early_init_pdc+0x99/0xa2
 [<ffffffff81384c75>] acpi_ns_walk_namespace+0xbe/0x179
 [<ffffffff81366ff0>] ? acpi_os_wait_semaphore+0x4a/0x61
 [<ffffffff81d370d6>] ? set_no_mwait+0x25/0x25
 [<ffffffff81d370d6>] ? set_no_mwait+0x25/0x25
 [<ffffffff8138512b>] acpi_walk_namespace+0x98/0xcb
 [<ffffffff81d36b87>] ? acpi_sleep_proc_init+0x2a/0x2a
 [<ffffffff81d371b2>] acpi_early_processor_set_pdc+0x3a/0x53
 [<ffffffff81d36cbf>] acpi_init+0x138/0x29b
 [<ffffffff813fb0d3>] ? __class_create+0x63/0xb0
 [<ffffffff8100215a>] do_one_initcall+0x12a/0x180
 [<ffffffff81d04033>] kernel_init_freeable+0x150/0x1df
 [<ffffffff81d03885>] ? do_early_param+0x8c/0x8c
 [<ffffffff81646680>] ? rest_init+0x80/0x80
 [<ffffffff8164668e>] kernel_init+0xe/0xf0
 [<ffffffff8166a22c>] ret_from_fork+0x7c/0xb0
 [<ffffffff81646680>] ? rest_init+0x80/0x80

Potential duplicate: bug 965962
Comment 1 Steven Ramacher 2013-06-15 23:37:00 EDT
Created attachment 761739 [details]
File: dmesg
Comment 2 Josh Boyer 2013-07-01 14:05:42 EDT
ACPI is hitting this WARN_ON_ONCE:

        /*
         * In the slowpath, we sanity check order to avoid ever trying to
         * reclaim >= MAX_ORDER areas which will never succeed. Callers may
         * be using allocators in order of preference for an area that is
         * too large.
         */
        if (order >= MAX_ORDER) {
                WARN_ON_ONCE(!(gfp_mask & __GFP_NOWARN));
                return NULL;
        }

So it's trying to allocate something large than MAX_ORDER.  That's generally a bad idea.
Comment 3 Justin M. Forbes 2013-10-18 17:11:47 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 18 kernel bugs.

Fedora 18 has now been rebased to 3.11.4-101.fc18.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you have moved on to Fedora 19, and are still experiencing this issue, please change the version to Fedora 19.

If you experience different issues, please open a new bug report for those.
Comment 4 Justin M. Forbes 2013-11-27 10:59:12 EST
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  

It has been over a month since we asked you to test the 3.11 kernel updates and let us know if your issue has been resolved or is still a problem. When this happened, the bug was set to needinfo.  Because the needinfo is still set, we assume either this is no longer a problem, or you cannot provide additional information to help us resolve the issue.  As a result we are closing with insufficient data. If this is still a problem, we apologize, feel free to reopen the bug and provide more information so that we can work towards a resolution

If you experience different issues, please open a new bug report for those.
Comment 5 Steven Ramacher 2015-03-23 09:54:22 EDT
I have no way to test, so I am closing this issue

Note You need to log in before you can comment on or make changes to this bug.