Bug 974835 - SELinux is preventing /usr/bin/mplayer from 'getattr' accesses on the file /home/brito/.mplayer/config.
SELinux is preventing /usr/bin/mplayer from 'getattr' accesses on the file /h...
Status: CLOSED DUPLICATE of bug 974836
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:46bfb621b9699cfe858c3c3d41c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-16 06:36 EDT by sabugiense
Modified: 2013-06-17 06:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-17 06:14:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sabugiense 2013-06-16 06:36:44 EDT
Description of problem:
SELinux is preventing /usr/bin/mplayer from 'getattr' accesses on the file /home/brito/.mplayer/config.

*****  Plugin restorecon (57.3 confidence) suggests  *************************

If você deseja reparar este rótulo.
/home/brito/.mplayer/config rótulo padrão deve ser mplayer_home_t.
Then você pode executar o restorecon.
Do
# /sbin/restorecon -v /home/brito/.mplayer/config

*****  Plugin mozplugger (43.1 confidence) suggests  *************************

If you want to use the plugin package
Then you must turn off SELinux controls on the Firefox plugins.
Do
# setsebool unconfined_mozilla_plugin_transition 0

*****  Plugin catchall (1.06 confidence) suggests  ***************************

If você acredita que o mplayer deva ser permitido acesso de getattr em config file  por default.
Then você precisa reportar este como um erro.
Você pode gerar um módulo de política local para permitir este acesso.
Do
permitir este acesso agora executando:
# grep mplayer /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/brito/.mplayer/config [ file ]
Source                        mplayer
Source Path                   /usr/bin/mplayer
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           mplayer-1.1-4.20121008svn.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-97.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-201.fc18.x86_64 #1 SMP Tue
                              Jun 11 19:40:51 UTC 2013 x86_64 x86_64
Alert Count                   4
First Seen                    2013-06-16 06:02:13 BRT
Last Seen                     2013-06-16 07:33:47 BRT
Local ID                      487bef26-7cde-419c-8d25-8b7bb9ec07df

Raw Audit Messages
type=AVC msg=audit(1371378827.757:830): avc:  denied  { getattr } for  pid=14081 comm="mplayer" path="/home/brito/.mplayer/config" dev="sda8" ino=2492417 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1371378827.757:830): arch=x86_64 syscall=fstat success=yes exit=0 a0=3 a1=7fff3d0cbe50 a2=7fff3d0cbe50 a3=0 items=0 ppid=1 pid=14081 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=mplayer exe=/usr/bin/mplayer subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)

Hash: mplayer,mozilla_plugin_t,user_home_dir_t,file,getattr

audit2allow

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_dir_t:file getattr;

audit2allow -R
require {
	type user_home_dir_t;
	type mozilla_plugin_t;
	class file getattr;
}

#============= mozilla_plugin_t ==============
allow mozilla_plugin_t user_home_dir_t:file getattr;


Additional info:
reporter:       libreport-2.1.4
hashmarkername: setroubleshoot
kernel:         3.9.5-201.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-06-17 06:14:26 EDT

*** This bug has been marked as a duplicate of bug 974836 ***

Note You need to log in before you can comment on or make changes to this bug.