Bug 974909 - Unable to sign in with new OpenId account
Unable to sign in with new OpenId account
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Authentication-OpenID (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Carlos Munoz
Ding-Yi Chen
:
: 976590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 02:23 EDT by David Mason
Modified: 2013-11-26 22:22 EST (History)
3 users (show)

See Also:
Fixed In Version: 3.0.0-alpha-2-SNAPSHOT (20130620-1218)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 22:22:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-06-17 02:23:15 EDT
Description of problem:
When attempting to sign in with an OpenId account that has not previously been used on the server, an account details form is shown, then an unexpected error occurs. It does not seem possible to sign in after this occurs.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Click 'Sign in' and select Fedora or Google OpenId
2. Complete the OpenId process with the provider
3. Enter a valid name, username and email address
4. Press OK

Actual results:
Message shows "An undepected error has occurred" and not signed in. Unable to sign in on subsequent attempts.

Expected results:
Sign in works


Additional info:
The above process adds a row to HAccount with the username, adds a row to HAccountActivationKey, adds a row to HPerson with the name and email address, 

Stack trace begins after persisting HPerson. e.g.

06:08:31,792 INFO  [org.zanata.model.HPerson] (http-/0.0.0.0:8080-10) persist entity: HPerson(super=HPerson@1ccd8a02[id=3,versionNum=0], name=David Mason)
06:08:31,797 WARNING [javax.enterprise.resource.webcontainer.jsf.lifecycle] (http-/0.0.0.0:8080-10) #{profileAction.edit}: java.lang.reflect.InvocationTargetException: javax.faces.FacesException: #{profileAction.edit}: java.lang.refl
ect.InvocationTargetException
        at com.sun.faces.application.ActionListenerImpl.processAction(ActionListenerImpl.java:117) [jsf-impl.jar:2.1.19-redhat-1]
        at net.bull.javamelody.JsfActionListener.processAction(JsfActionListener.java:65) [javamelody-core-1.41.0.jar:1.41.0]
        at javax.faces.component.UICommand.broadcast(UICommand.java:315) [jboss-jsf-api_2.1_spec.jar:2.1.19.1.Final-redhat-1]
        at javax.faces.component.UIViewRoot.broadcastEvents(UIViewRoot.java:786) [jboss-jsf-api_2.1_spec.jar:2.1.19.1.Final-redhat-1]
        at javax.faces.component.UIViewRoot.processApplication(UIViewRoot.java:1251) [jboss-jsf-api_2.1_spec.jar:2.1.19.1.Final-redhat-1]
Comment 1 Carlos Munoz 2013-06-19 00:12:07 EDT
This is caused by an incompatibility in the versions of hibernate and hibernate-search used since the upgrade to EAP 6.1.

Upgraded hibernate-search to a compatible version.

See:
https://github.com/zanata/zanata-server/commit/b2942c6440c31823e3ae2938ab5443c62089290e
Comment 2 Ding-Yi Chen 2013-06-20 03:03:11 EDT
VERIFIED with Zanata version 3.0.0-alpha-2-SNAPSHOT (20130620-1218)
Comment 3 Alex Eng 2013-06-20 20:46:16 EDT
*** Bug 976590 has been marked as a duplicate of this bug. ***
Comment 4 Sean Flanigan 2013-11-26 22:22:23 EST
Closing bugs which were VERIFIED with snapshots <= 3.1.

Note You need to log in before you can comment on or make changes to this bug.