Bug 974922 - grub2 boot problems after updating to grub2-tools-2.00-20 and grub2-2.00-20
grub2 boot problems after updating to grub2-tools-2.00-20 and grub2-2.00-20
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-17 03:00 EDT by Joachim Backes
Modified: 2013-07-06 06:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-06 06:45:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-06-17 03:00:17 EDT
Description of problem:
the "jumbo" update from this morning (Germany!) includes an update of 
grub2 and grub2-tools to the version given in the subject.

Problems:

1. If booting, grub2 complains about

/boot/grub2/themes/system/DejeVuSans-10.pf2 not found
/boot/grub2/themes/system/DejeVuSans-12.pf2 not found
/boot/grub2/themes/system/DejeVuSans-Bold-14pf2 not found
/boot/grub2/themes/system/theme.txt not found

2. I miss the standard grub2 colored graphical display background during 
the OS selection (b/w only)


Getting rid of this probs by downgrading grub2 and grub2-tools.

Version-Release number of selected component (if applicable):
grub2-tools-2.00-20 and grub2-2.00-20

How reproducible:
always

Steps to Reproduce:
1.update to grub2-tools-2.00-20 and grub2-2.00-20
2.reboot
3.

Actual results:
Grub2 error msgs as described, no graphical display background

Expected results:
ols behaviour

Additional info:
Comment 1 Joachim Backes 2013-06-17 03:30:30 EDT
I think, grub2 looks in the wrong directory (system and starfield exchanged?)

ls -l /boot/grub2/themes/*
/boot/grub2/themes/starfield:
total 2824
-rw-r--r--. 1 root root     836 Apr 10 22:20 blob_w.png
-rw-r--r--. 1 root root     178 Apr 10 22:20 boot_menu_c.png
-rw-r--r--. 1 root root     193 Apr 10 22:20 boot_menu_e.png
-rw-r--r--. 1 root root     193 Apr 10 22:20 boot_menu_ne.png
-rw-r--r--. 1 root root     103 Apr 10 22:20 boot_menu_n.png
-rw-r--r--. 1 root root     184 Apr 10 22:20 boot_menu_nw.png
-rw-r--r--. 1 root root     198 Apr 10 22:20 boot_menu_se.png
-rw-r--r--. 1 root root     102 Apr 10 22:20 boot_menu_s.png
-rw-r--r--. 1 root root     196 Apr 10 22:20 boot_menu_sw.png
-rw-r--r--. 1 root root      96 Apr 10 22:20 boot_menu_w.png
-rw-r--r--. 1 root root   19890 Apr 10 22:20 COPYING.CC-BY-SA-3.0
-rw-r--r--. 1 root root  146357 Apr 10 22:20 dejavu_10.pf2
-rw-r--r--. 1 root root  160939 Apr 10 22:20 dejavu_12.pf2
-rw-r--r--. 1 root root  176345 Apr 10 22:20 dejavu_14.pf2
-rw-r--r--. 1 root root  194498 Apr 10 22:20 dejavu_16.pf2
-rw-r--r--. 1 root root  183394 Apr 10 22:20 dejavu_bold_14.pf2
-rw-r--r--. 1 root root    1191 Apr 10 22:20 README
-rw-r--r--. 1 root root     197 Apr 10 22:20 slider_c.png
-rw-r--r--. 1 root root     265 Apr 10 22:20 slider_n.png
-rw-r--r--. 1 root root     269 Apr 10 22:20 slider_s.png
-rw-r--r--. 1 root root 1897028 Apr 10 22:20 starfield.png
-rw-r--r--. 1 root root     178 Apr 10 22:20 terminal_box_c.png
-rw-r--r--. 1 root root      94 Apr 10 22:20 terminal_box_e.png
-rw-r--r--. 1 root root     128 Apr 10 22:20 terminal_box_ne.png
-rw-r--r--. 1 root root     194 Apr 10 22:20 terminal_box_n.png
-rw-r--r--. 1 root root     210 Apr 10 22:20 terminal_box_nw.png
-rw-r--r--. 1 root root     126 Apr 10 22:20 terminal_box_se.png
-rw-r--r--. 1 root root     101 Apr 10 22:20 terminal_box_s.png
-rw-r--r--. 1 root root     123 Apr 10 22:20 terminal_box_sw.png
-rw-r--r--. 1 root root      97 Apr 10 22:20 terminal_box_w.png
-rw-r--r--. 1 root root    2249 Apr 10 22:20 theme.txt

/boot/grub2/themes/system:
total 8080
-rw-r--r--. 1 root root 4134586 Apr  4 21:44 background.png
-rw-r--r--. 1 root root 4134586 Apr  4 21:44 fireworks.png
Comment 2 Joachim Backes 2013-06-17 05:26:52 EDT
By rerunning grub2-mkconfig I got rid of the messages

/boot/grub2/themes/system/DejeVuSans-10.pf2 not found
/boot/grub2/themes/system/DejeVuSans-12.pf2 not found
/boot/grub2/themes/system/DejeVuSans-Bold-14pf2 not found
/boot/grub2/themes/system/theme.txt not found

But still I have no star bootscreen, even after installing
grub2-starfield-theme.
Comment 3 Pavel Roskin 2013-07-05 23:59:03 EDT
grub2 complains about files that are part of the grub2-starfield-theme package.  No idea why.  Please check /etc/default/grub and comment out GRUB_THEME.

/boot/grub2/themes/starfield must be a leftover from an earlier installation.  grub2-starfield-theme-2.00-23.fc19.x86_64 installs files into /boot/grub2/themes/system.

The starfield theme is incomplete.  /boot/grub2/themes/system/theme.txt refers to a file fireworks.png that is not included.
Comment 4 Pavel Roskin 2013-07-06 00:13:22 EDT
It turns out /boot/grub2/themes/starfield is created when grub.cfg is regenerated:

grub2-mkconfig -o /boot/grub2/grub.cfg

/boot/grub2/themes/starfield/theme.txt refers to starfield.png that is present.  So you just need to add this to /etc/default/grub:

GRUB_THEME=/boot/grub2/themes/starfield/theme.txt

Then regenerate grub.cfg and you should have the graphical theme on reboot.
Comment 5 Joachim Backes 2013-07-06 06:45:10 EDT
OK! Works for me with this info!

Note You need to log in before you can comment on or make changes to this bug.